Filewatcher File Search File Search
Catalog
Content Search
» » » »

python-poppler-qt4_0.16.2.orig.tar.gz

Homepage:-
Package version:-
Architecture:-
Distribution:Debian
Filename:python-poppler-qt4_0.16.2.orig.tar.gz

/python-poppler-qt4-0.16.2/README

python-poppler-qt4
==================

A Python binding for libpoppler-qt4 that aims for completeness and for being
actively maintained.

Created and currently maintained by Wilbert Berendsen <wbsoft@xs4all.nl>.


Usage:
======

import popplerqt4

d = popplerqt4.Poppler.Document.load('file.pdf')


Documentation:
==============

The Python API closely follows the Poppler Qt4 C++ interface library A
more»

/python-poppler-qt4-0.16.2/ChangeLog

Version 0.16.2 -- May 20th, 2011

* Fix gcc-4.6 compile (issue #4)

Version 0.16.1 -- March 21th, 2011

* Installation: fix 'sys not defined' error (issue #3)
* Poppler version can now be set with build_ext --poppler-version

Version 0.16.0 -- February 8th, 2011

* API updated for Poppler-0.16.0
* Version numbering on par with Poppler
* Release the GIL on time-consuming calls
* Poppler::FontIterat
more»

/python-poppler-qt4-0.16.2/TODO

TODO:

- test Python versions other than 2.6
- add some examples

DONE:
- Poppler::Document::newFontIterator() is usable as Python iterable
- Poppler::HighlightAnnotation::Quad.points has been fixed
- support Poppler::InkAnnotation::inkPaths() and setInkPaths()
- cast returned lists of objects like Document::links() to their respective types
- convert to and from QLinkedList


/python-poppler-qt4-0.16.2/LICENSE

This binding is licensed under the GNU LGPL.

Copyright (c) 2009-2010  Wilbert Berendsen (www.wilber
more»

Browse inside python-poppler-qt4_0.16.2.orig.tar.gz

         [DIR]python-poppler-qt4-0.16.2/ (15)  10 mirrors

Download python-poppler-qt4_0.16.2.orig.tar.gz

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016 FileWatcher.com