Filewatcher File Search File Search
Content Search
» » » » »


constraints satisfaction solver in Python

Extensible constraint satisfaction problem solver written in pure Python, using constraint propagation algorithms. The logilab.constraint module provides finite domains with arbitrary values, finite interval domains, and constraints which can be applied to variables linked to these domains.
Package version:0.4.0-5


This package implements constraint propagation algorithm to solve
constraint satisfaction problem. It requires python 2.3 or later to
work. Having psyco ( installed will definitely
speed up things, but is not a requirement.

It is released under the GNU Public License. 

The documentation is in the doc/ directory. Examples are in the
examples/ directory.

Discussion about const


logilab-constraint (0.4.0-5) unstable; urgency=low

  [ Luca Falavigna ]
  * debian/rules:
    - Use *-packages wildcard when removing files, Python 2.6 installs files
      under /usr/lib/python*/dist-packages (Closes: #547829).

 -- Debian Python Modules Team <>  Mon, 28 Sep 2009 23:05:00 +0200

logilab-constraint (0.4.0-4) unstable; urgency=medium



ChangeLog for logilab.constraint

2008-08-07  --  0.4.0
    * allow capture of solver output

2005-09-05  --  0.3.0
    * Added finite interval domains and constraints in module

    * constraint now depends on logilab.common to support a larger number
      of python versions 

    * Optimisation of finite domains by using copy on write



This package was debianized by Alexandre Fayolle <>  Sat, 13 Apr 2002 19:05:23 +0


Alexandre Fayolle: core coding
Herb Schilling: documentation proof reading
Terry Reedy: documentatio

Browse inside python-logilab-constraint_0.4.0-5_all.deb

         [DIR]DEBIAN/ (4)  65535+ mirrors
         [DIR]usr/ (1)  65535+ mirrors

Download python-logilab-constraint_0.4.0-5_all.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016