Filewatcher File Search File Search
Catalog
Content Search
» » » » »

libhighline-ruby1.9.1

High-level interactive IO Ruby 1.9.1 library

High-level IO library that provides validation, type conversion, and more for command-line interfaces. HighLine also includes a complete menu system that can crank out anything from simple list selection to complete shells with just minutes of work.
Homepage:
Package version:1.5.2-1
Architecture:all
Distribution:Debian
Filename:libhighline-ruby1.9.1_1.5.2-1_all.deb

/usr/share/doc/libhighline-ruby1.9.1/README

= Read Me

by James Edward Gray II

== Description

Welcome to HighLine.

HighLine was designed to ease the tedious tasks of doing console input and
output with low-level methods like gets() and puts().  HighLine provides a
robust system for requesting data from a user, without needing to code all the
error checking and validation rules and without needing to convert the typed
Strings into what yo
more»

/usr/share/doc/libhighline-ruby1.9.1/changelog.Debian.gz

libhighline-ruby (1.5.2-1) unstable; urgency=low

  [ Ryan Niebur ]
  * set myself as Maintainer

  [ Paul van Tilburg ]
  * New upstream release. 
  * Added support for Ruby 1.9.1.
  * debian/control:
    - Bumped standards version to 3.8.4.
    - Bumped debhelper build-depend to >= 5.
    - Added a libhighline-ruby1.9.1 package entry.
    - Added a build depend on ruby1.9.1.

 -- Paul van Tilbur
more»

/usr/share/doc/libhighline-ruby1.9.1/changelog.gz

= Change Log

Below is a complete listing of changes for each revision of HighLine.

== 1.5.2

* Added support for using the ffi-ncurses gem which is supported in JRuby.
* Added gem build instructions.

== 1.5.1

* Fixed the long standing echo true bug.
  (reported by Lauri Tuominen)
* Improved Windows API calls to support the redirection of STDIN.
  (patch by Aaron Simmons)
* Updated gem specific
more»

/usr/share/doc/libhighline-ruby1.9.1/TODO

= To Do List

The following is a list of planned expansions for HighLine, in no particular
order.

*
more»

/usr/share/doc/libhighline-ruby1.9.1/copyright

This package was debianized by Esteban Manchado Velázquez <zoso@debian.org> on
Fri Jun  9 22:26:18 
more»

Browse inside libhighline-ruby1.9.1_1.5.2-1_all.deb

         [DIR]DEBIAN/ (2)  65535+ mirrors
         [DIR]usr/ (2)  65535+ mirrors

Download libhighline-ruby1.9.1_1.5.2-1_all.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016 FileWatcher.com