Filewatcher File Search File Search
Content Search
» » » » »


Simple, extensible, embeddable programming language

Lua is a powerful, light-weight programming language designed for extending applications. The language engine is accessible as a library, having a C API which allows the application to exchange data with Lua programs and also to extend Lua with C functions. Lua is also used as a general-purpose, stand-alone language through the simple command line interpreter provided.

This package contains developer resources for using the Lua library. Install it if you are developing programs which use the Lua C API.

Package version:5.1.4-5


lua5.1 for Debian

This is packaging for Debian of the 5.1 series of the Lua programming
language.  For package development see <>.

Binary package index:

    * lua5.1 - command line tools (i.e. interpreter and bytecode compiler)
    * lua5.1-doc - documentation, including manual and examples
    * liblua5.1-0-dev - development libraries
    * li


lua5.1 (5.1.4-5) unstable; urgency=low

  * Fixed #include directives and calls to luaopen_* in the examples. 
    Thanks Mike Pall for reporting that (private mail).

 -- Enrico Tassi <>  Thu, 05 Nov 2009 20:44:38 +0100

lua5.1 (5.1.4-4) unstable; urgency=low

  * build-depend on libreadline-dev (and not libreadline5-dev) to
    help the transition to libreadline6 (Closes


This package was debianized by John V. Belmonte <> on
Sun, 20 Nov 2005 19:55:05 -0500.

It was downloaded from <>.

Copyright Holder: Lua Team <>


Copyright (C) 1994-2005, PUC-Rio.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the "Software")

Browse inside liblua5.1-0-dev_5.1.4-5_amd64.deb

         [DIR]DEBIAN/ (2)  65535+ mirrors
         [DIR]usr/ (3)  65535+ mirrors

Download liblua5.1-0-dev_5.1.4-5_amd64.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016