Filewatcher File Search File Search
Catalog
Content Search
» » » » »

libmpfi-dev

multiple precision floating-point interval computation library

Variants:
This package provides a C library of functions for interval arithmetic computations with arbitrary precision.

The basic principle of interval arithmetic consists in enclosing every number by an interval containing it and being representable by machine numbers: for instance it can be stored as its lower and upper endpoints and these bounds are machine numbers, or as a centre and a radius which are machine numbers.

The arithmetic operations are extended for interval operands in such a way that the exact result of the operation belongs to the computed interval.

The purpose of an arbitrary precision interval arithmetic is on the one hand to get guaranteed results, thanks to interval computation, and on the other hand to obtain accurate results, thanks to multiple precision arithmetic. The MPFI library is built upon MPFR in order to benefit from the correct roundings provided by MPFR. Further advantages of using MPFR are its portability and compliance with the IEEE 754 standard for floating-point arithmetic.

Homepage:
Package version:1.4-1
Architecture:amd64
Distribution:Debian
Filename:libmpfi-dev_1.4-1_amd64.deb

/usr/share/doc/libmpfi-dev/README

To install MPFI library :

./configure extra options (read INSTALL for general options)

--with-gmp-dir=<gmp installation directory>

Note that default install path is /usr/local/lib.
Systems like Debian do not search libraries at this place by default.
If you compile a soft using mpfi and have an error at execution time such as:

error while loading shared libraries: libmpfi.so.0: cannot open sh
more»

/usr/share/doc/libmpfi-dev/NEWS.gz

Copyright 1999, 2000, 2001, 2002 - 2009 Spaces project, Inria Lorraine
                     and Arenaire project, Inria Rhone-Alpes, France
                     and Lab. ANO, USTL (Univ. of Lille),  France


This file is part of the MPFI Library.

The MPFI Library is free software; you can redistribute it and/or modify
it under the terms of the GNU Lesser General Public License as published by
the
more»

/usr/share/doc/libmpfi-dev/changelog.Debian.gz

mpfi (1.4-1) unstable; urgency=low

  * New upstream version.
  * Switch to quilt format.
  * Remove references to mpfr_random (closes: #590355).
  * Upgrade Standard-Version to 3.9.0 (no change needed).

 -- Laurent Fousse <laurent@komite.net>  Mon, 26 Jul 2010 14:11:18 +0200

mpfi (1.3.4~rc4~cvs20080519-1) unstable; urgency=low

  * Package current CVS version.
  * Add new dynamic library packag
more»

/usr/share/doc/libmpfi-dev/changelog.gz

2009-04-22 19:07  schevill

	* README: reverted nothing

2009-04-22 19:05  schevill

	* README: noth
more»

/usr/share/doc/libmpfi-dev/copyright

This package was debianized by Laurent Fousse <laurent@komite.net> on
Wed, 10 Aug 2005 15:47:28 +020
more»

Browse inside libmpfi-dev_1.4-1_amd64.deb

         [DIR]DEBIAN/ (2)  65535+ mirrors
         [DIR]usr/ (3)  65535+ mirrors

Download libmpfi-dev_1.4-1_amd64.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016 FileWatcher.com