Filewatcher File Search File Search
Content Search
» » » » »


A PHP5 extension for PAM authentication

pam-auth is a PHP extension, that enables PHP scripts to use PAM to authenticate users.

This is the extension for php5.

Package version:0.4-10+b1


pam_auth is a simple extension to allow you to authenticate people using pam.
It consists of only one very easy to use function. 

I will now proceed to explain how to use it in one easy step. Please be sure to
read all of the instructions in the INSTALL file prior to trying it out.

The following code snippet shows the complete usage of pam_auth.

if (pam_auth($username, $password, &$error)) 


php-auth-pam for Debian
In a normal Debian installation, where PAM operates on a local shadow file,
pam_auth() will return the error "Authentication Failure" (see FAQ).

This will not be changed per default, because doing so would mean to allow 
the webserver to access the shadow file, wich is to be considered a security 
risc. Please do not file Bugreports reg


* What is PAM?

PAM stands for Pluggable Authentication Module. It is a system that abstracts
user authentication to allow arbitrary modules to handle the real work. In this
way, pam enabled services can use a variety of complex authentication schemes
without modifying the applications. For more Information, and available
modules, see

* Why would I wan


php-auth-pam (0.4-10+b1) unstable; urgency=low

  * Binary-only non-maintainer upload for amd64; no 


pam_auth 0.4 - 7/9/03

- finally loads as a shared module thanks to tips from Alan Knowles
- cleane


This package was debianized by Carsten Wolff <>
on Wed, 16 Jun 2004 17:24:42 

Browse inside php5-auth-pam_0.4-10+b1_amd64.deb

         [DIR]DEBIAN/ (3)  65535+ mirrors
         [DIR]etc/ (1)  65535+ mirrors
         [DIR]usr/ (2)  65535+ mirrors

Download php5-auth-pam_0.4-10+b1_amd64.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016