Filewatcher File Search File Search
Catalog
Content Search
» » » » »

libsqlite3-ruby1.9.1

SQLite3 interface for Ruby 1.9.1

Variants:
SQLite3/Ruby module allows Ruby programs to interface with the SQLite3 database engine.

Note that this module is NOT compatible with SQLite 2.x.

This package contains SQLite3 module for Ruby 1.9.1.

Homepage:
Package version:1.2.4-2.1
Architecture:i386
Distribution:Debian
Filename:libsqlite3-ruby1.9.1_1.2.4-2.1_i386.deb

/usr/share/doc/libsqlite3-ruby1.9.1/README.rdoc

= SQLite3/Ruby Interface

This module allows Ruby programs to interface with the SQLite3
database engine (http://www.sqlite.org).  You must have the
SQLite engine installed in order to build this module.

Note that this module is NOT compatible with SQLite 2.x.


== Compilation and Installation

Simply do the following, after installing SQLite3:

  ruby setup.rb config
  ruby setup.rb setup
  ruby
more»

/usr/share/doc/libsqlite3-ruby1.9.1/faq/faq.html

<html>
  <head>
    <title>SQLite3/Ruby FAQ</title>
    <style type="text/css">
      a, a:visited, a:active {
        color: #00F;
        text-decoration: none;
      }

      a:hover {
        text-decoration: underline;
      }

      .faq-list {
        color: #000;
        font-family: vera-sans, verdana, arial, sans-serif;
      }

      .faq-title {
        background: #007;
        color:
more»

/usr/share/doc/libsqlite3-ruby1.9.1/faq/faq.rb

require 'yaml'
require 'redcloth'

def process_faq_list( faqs )
  puts "<ul>"
  faqs.each do |faq|
    process_faq_list_item faq
  end
  puts "</ul>"
end

def process_faq_list_item( faq )
  question = faq.keys.first
  answer = faq.values.first

  print "<li>"

  question_text = RedCloth.new(question).to_html.gsub( %r{</?p>},"" )
  if answer.is_a?( Array )
    puts question_text
    process_faq_lis
more»

/usr/share/doc/libsqlite3-ruby1.9.1/faq/faq.yml.gz

---
- "How do I do a database query?":
  - "I just want an array of the rows...": >-

      Use the 
more»

/usr/share/doc/libsqlite3-ruby1.9.1/changelog.Debian.gz

sqlite3-ruby (1.2.4-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Switch from Ruby 1.9 
more»

/usr/share/doc/libsqlite3-ruby1.9.1/changelog.gz

=== 1.2.4 / 27 Aug 2008

* Package the updated C file for source builds. [Jamis Buck]


=== 1.2.3 / 
more»

/usr/share/doc/libsqlite3-ruby1.9.1/copyright

Author: Jamis Buck <jgb3@email.byu.edu>

Copyright (c) 2004, Jamis Buck (jgb3@email.byu.edu)
All rig
more»

Browse inside libsqlite3-ruby1.9.1_1.2.4-2.1_i386.deb

         [DIR]DEBIAN/ (2)  65535+ mirrors
         [DIR]usr/ (2)  65535+ mirrors

Download libsqlite3-ruby1.9.1_1.2.4-2.1_i386.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016 FileWatcher.com