Filewatcher File Search File Search
Content Search
» » » » »


GPGME bindings for the Ruby language

GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management.

This package is built for Ruby 1.9.

Package version:1.0.1-2


* What's this?

Ruby-GPGME is a Ruby language binding of GPGME (GnuPG Made Easy).

* Requirements

- Ruby 1.8 or later
- GPGME 1.1.2 or later
- gpg-agent (optional, but recommended)

* Installation

 $ ruby extconf.rb
 $ make
 $ make install

* Examples

 examples/genkey.rb	Generate a key pair in your keyring.
 examples/keylist.rb	List your keyring like gpg --list-keys.
 examples/roundtrip.rb  Enc


libgpgme-ruby (1.0.1-2) unstable; urgency=low

  * Build-depend on ruby-pkg-tools >= 0.14, than fixes the ruby1.9 libs
    install problem (see #484611).

 -- Lucas Nussbaum <>  Mon, 16 Jun 2008 15:06:45 +0200

libgpgme-ruby (1.0.1-1) unstable; urgency=low

  * New upstream release.  Removed patch for memleak fixed by upstream.

 -- Rudi Cilibrasi <>  Thu


This package originally Debianised
by Thierry Reding <>, on February 3rd, 2006.

Originally obtained from <>.

Copyright: 2006-2008  Daiki Ueno

This project is distributed under the GPL.

On Debian systems, the full text of the GNU General Public License
can be found at /usr/share/common-licenses/GPL.

Browse inside libgpgme-ruby1.9_1.0.1-2_i386.deb

         [DIR]DEBIAN/ (2)  65535+ mirrors
         [DIR]usr/ (2)  65535+ mirrors

Download libgpgme-ruby1.9_1.0.1-2_i386.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016