Filewatcher File Search File Search
Content Search
» » » » »


Perl extension for Cyrus SASL library

This module provides an Perl interface to the Cyrus implementation of SASL. It works with the existing Authen::SASL implementation, has been tested with Net::LDAP, and provides the GSSAPI authentication layer.

This version of the Authen::SASL::Cyrus includes an interface to the server-side functionality of the SASL library.

Package version:0.13-server-5


Authen::SASL::Cyrus - XS code to glue Perl SASL to Cyrus SASL

1. Build Authen::SASL::Cyrus

First of all you need Authen::SASL installed at least in version 2.06 (with
server patch or higher).

Then run the Makefile.PL:

If you want to link it with SASL v1 library:

# perl Makefile.PL LIBS="-lsasl"

if your SASL library is located in another path:

# perl Makefile.PL INC=-I/opt/products/sasl/1.5.


libauthen-sasl-cyrus-perl (0.13-server-5) unstable; urgency=low

  * Add the missing $(QUILT_STAMPFN) dependency to debian/rules so that
    patches are applied correctly during the build.  Thanks, Ben
    Poliakoff.  (Closes: #538296)
  * Update standards version to 3.8.2 (no changes required).

 -- Russ Allbery <>  Fri, 24 Jul 2009 10:05:02 -0700

libauthen-sasl-cyrus-perl (0.13-se


History of updates to Authen::SASL::Cyrus


Russ Allbery: the 0.12-server distribution of this module has a typemap that
ends up casting the pointer return from server_new and client_new through an
int.  This looks like it's causing pointer truncation and various problems on
some 64-bit platforms (particularly Debian alpha and Debian ia64).

There is a simpler fix than the patch below 


Debianized by Graeme Mathieson <>               2001-11-22
Adopted by Stephen Zander

Browse inside libauthen-sasl-cyrus-perl_0.13-server-5_i386.deb

         [DIR]DEBIAN/ (2)  65535+ mirrors
         [DIR]usr/ (2)  65535+ mirrors

Download libauthen-sasl-cyrus-perl_0.13-server-5_i386.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016