Filewatcher File Search File Search
Catalog
Content Search
» » » » »

libapache2-mod-authnz-external

authenticate Apache against external authentication services

Variants:
Mod_Auth_External can be used to quickly construct secure, reliable authentication systems. It can also be mis-used to quickly open gaping holes in your security. Read the documentation, and use with extreme caution.

Notably, this module can be used to securely authenticate against PAM (without exposing /etc/shadow file), using, for example, pwauth authenticator.

This Package includes the mod-athnz-external Module for Apache Version 2.x

Homepage:
Package version:3.2.4-2.1
Architecture:ia64
Distribution:Debian
Filename:libapache2-mod-authnz-external_3.2.4-2.1_ia64.deb

/usr/share/doc/libapache2-mod-authnz-external/README.Debian

This package can be used with pwauth to provide secure auth against PAM without
exposing /etc/shadow file.

To use it on Debian, make sure to also pwauth package then add these lines to
relevant Location or Directory section:
    AuthBasicProvider external
    AuthExternal pwauth

And to the related virtual host section:
   AddExternalAuth pwauth /usr/sbin/pwauth
   SetExternalAuthMethod pwauth pi
more»

/usr/share/doc/libapache2-mod-authnz-external/README.gz

                   Mod_Authnz_External version 3.2.4

     Original Coder: Nathan Neulinger <nneul@umr.edu>
Previous Maintainer: Tyler Allison    <allison@nas.nasa.gov>
 Current Maintainer: Jan Wolter       http://www.unixpapa.com
    Apache 2.0 Port: Dave Woolaway    <dave@watersheep.org>
    		     Sven Koch        <haegar@sdinet.de>
    Apache 2.2 Port: Jan Wolter       http://www.unixpapa.com

more»

/usr/share/doc/libapache2-mod-authnz-external/changelog.Debian.gz

libapache2-mod-authnz-external (3.2.4-2.1) unstable; urgency=high

  * Non-maintainer upload by the security team
  * Fix SQL injection via the $user paramter (Closes: #633637)
    Fixes: CVE-2011-2688

 -- Steffen Joeris <white@debian.org>  Mon, 18 Jul 2011 10:26:11 +1000

libapache2-mod-authnz-external (3.2.4-2) unstable; urgency=low

  * libapache2-mod-authnz-external does not install the .load
more»

/usr/share/doc/libapache2-mod-authnz-external/changelog.gz

v3.2.4   (Jan Wolter - May 20, 2009)
-----------------------------------------------
 * Dropped the 
more»

/usr/share/doc/libapache2-mod-authnz-external/copyright

This package was debianized for Ubuntu by Chuck Short <zulcss@ubuntu.com> on
Tue, 08 Jan 2008 10:20:
more»

Browse inside libapache2-mod-authnz-external_3.2.4-2.1_ia64.deb

         [DIR]DEBIAN/ (3)  65535+ mirrors
         [DIR]etc/ (1)  65535+ mirrors
         [DIR]usr/ (2)  65535+ mirrors

Download libapache2-mod-authnz-external_3.2.4-2.1_ia64.deb

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2016 FileWatcher.com