Filewatcher File Search File Search
Catalog
Content Search
» » » » GnuPG-0.19.tar.gz » Content »
pkg://GnuPG-0.19.tar.gz:32665/GnuPG-0.19/debian/  info  downloads

changelog

libgnupg-perl (0.9-9) unstable; urgency=low

  * Make/sh prefers "! [ -d foo ]" over "![ -d foo ]".  It didn't really
    matter because there was a "|| rmdir foo" after that and the directory
    existed, but it prints ugly warnings that I missed before.

 -- Peter Palfrader <weasel@debian.org>  Sun, 18 Jun 2006 01:32:22 +0200

libgnupg-perl (0.9-8) unstable; urgency=low

  * Move debhelper from Build-Depends-Indep to Build-Depends.
  * Apply patch by Andrew Suffield to handle key retrival by GnuPG caused by
    'keyserver-options auto-key-retrieve' (closes: #269627).  Thanks.
  * Apply patch by Andrew Suffield to properly propagte that reason
    for verification errors when the key is not around (closes: #310792).
    Thanks once more.
  * Instead of defining INSTALLBIN, INSTALLSCRIPT, etc just say
    INSTALLDIRS=vendor in debian/rules, and set PREFIX for the install.
  * Also use make install and not make pure_install.
  * Remove code to remove .packlist files from the install target.
  * Remove lots of comments (and unused, commented out lines) from
    debian/rules.
  * Remove usr/sbin from debian/dirs (debhelper).  We don't put anything
    there.
  * Remove empty usr/lib/perl5 and usr/lib after make install.
  * Update Standards-Version to 3.7.2 from 3.6.1 (without additional changes).

 -- Peter Palfrader <weasel@debian.org>  Sat, 17 Jun 2006 20:43:37 +0200

libgnupg-perl (0.9-7) unstable; urgency=low

  * GnuPG::Perl looks to be quite unmaintained upstream, so I recomment
    people use other modules, like GnuPG::Interface maybe, however
    apply Adrian's patch for his POLICY_URL problem.  GnuPG.pm would
    complain about protocol violations when a signature had more
    information (like a POLICY_URL) than it expected (Closes: #316065).
  * Change from debhelper compat level 2 to 4, and change build depends
    accordingly.

 -- Peter Palfrader <weasel@debian.org>  Sun, 10 Jul 2005 11:53:08 +0200

libgnupg-perl (0.9-6) unstable; urgency=low

  * GnuPG 1.2.5 introduced a few more status lines when decrypting/verifying
    files.  GnuPG.pm would not handle that properly.  We now eat all the
    status lines in decrypt_postread() (closes: #298556).

 -- Peter Palfrader <weasel@debian.org>  Tue,  8 Mar 2005 20:55:41 +0100

libgnupg-perl (0.9-5) unstable; urgency=low

  * Change section to perl to fix override disparity.

 -- Peter Palfrader <weasel@debian.org>  Sun, 25 Apr 2004 16:46:09 +0200

libgnupg-perl (0.9-4) unstable; urgency=low

  * Install non binary perl into usr/share rather than usr/lib.
  * Slight changes to debian/copyright: replace "author(s)" with
    "author", refer to GPL-2 rather than GPL.
  * Update standards version to 3.6.1.
  * Fix build dependency on debhelper: it needs to be versioned (>=2).
  * Don't end short desciprtion with a dot.

 -- Peter Palfrader <weasel@debian.org>  Sun, 25 Apr 2004 15:27:54 +0200

libgnupg-perl (0.9-3) unstable; urgency=low

  * New Standards-Version: 3.5.7
    - Have no /usr/doc link anymore (actually building against the new
      debhelper does fix this - I'll not depend on it tho to make
      building it on older releases easier)
    - Change Build-Depends to Build-Depends-Indep

 -- Peter Palfrader <weasel@debian.org>  Mon, 11 Nov 2002 13:37:14 +0100

libgnupg-perl (0.9-2) unstable; urgency=low

  * Moved from non-US to main (Section: interpreters).

 -- Peter Palfrader <weasel@debian.org>  Mon, 17 Jun 2002 20:25:34 +0200

libgnupg-perl (0.9-1) unstable; urgency=low

  * New upstream version (closes: #99647);
  * Upped Standards-Version to 3.5.4.
  * Applied patch to make it work under strict subs:
    @@ -267 +267 @@
    -       my $max_fd = POSIX::sysconf( POSIX::_SC_OPEN_MAX ) || 256;
    +       my $max_fd = POSIX::sysconf( &POSIX::_SC_OPEN_MAX ) || 256;
    Thanks to Radu Muschevici <radu@stusta.mhn.de> (closes: #117689).
  * Also remove empty stuff from usr/lib/perl.

 -- Peter Palfrader <weasel@debian.org>  Wed,  7 Nov 2001 17:23:00 +0100

libgnupg-perl (0.7-2) unstable; urgency=low

  * Fixed example in GnuPG::Tie manpage (closes: #90703).
  * Upped Standards-Version to 3.5.2.
  * Removed dependency on perl5. perl-base is essential and sufficent.

 -- Peter Palfrader <weasel@debian.org>  Sun, 25 Mar 2001 21:07:14 +0200

libgnupg-perl (0.7-1) unstable; urgency=low

  * Initial Release (closes: #76184).

 -- Peter Palfrader <weasel@debian.org>  Thu,  4 Jan 2001 02:21:44 +0100
Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2017 FileWatcher.com