Filewatcher File Search File Search
Catalog
Content Search
» » » » » libkdecore5_4.4.5-2+squeeze3_amd64.deb » Content »
pkg://libkdecore5_4.4.5-2+squeeze3_amd64.deb:1115362/usr/share/doc/libkdecore5/  info  control  downloads

libkdecore5 - the KDE Platform Core Library…  more info»

changelog.Debian.gz

kde4libs (4:4.4.5-2+squeeze3) stable; urgency=low

  [ Ansgar Burchardt ]
  * Apply upstream patch to prevent marked text being cut out when switching
    documents in kate. (Closes: #636615)
    + new patch: 636615-ibus.diff

 -- Modestas Vainius <modax@debian.org>  Sun, 04 Sep 2011 09:28:50 +0300

kde4libs (4:4.4.5-2+squeeze2) stable; urgency=low

  [ José Manuel Santamaría Lema ]
  * Fix CVE-2011-1168 (Konqueror partially universal XSS in error pages) by
    cve_2011_1168_konqueror_xss.diff.
  * Fix CVE-2010-3170 (browser wildcard cerficate validation weakness) for
    Konqueror by cve_2010_3170_cn_wildcards.diff.
  * Fix CVE-2011-1094 (kdelibs does not properly verify that the server hostname
    matches the Common Name of the Subject of an X.509 certificate if that CN is
    an IP address) by cve_2011_1094_ssl_verify_hostname.diff.

  [ Modestas Vainius ]
  * KTar: use unsigned arithmetic when calculating checksum of tar header record
    (as per ustar specification). However, when reading archive, verify
    checksum by calculating it both ways (unsigned and signed) and accept if
    either matches (partially solves #612675). Implemented in
    ktar_header_checksum_fix.diff patch.
  * Fix KTar longlink support when filenames are encoded in the UTF-8 (or other
    multibyte) locale. Implemented in ktar_longlink_length_in_bytes.diff patch
    (thanks to Ibragimov Rinat). Closes: #612675

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 14 Jun 2011 00:13:57 +0300

kde4libs (4:4.4.5-2+squeeze1) stable-proposed-updates; urgency=low

  * Add a kconf_update script (migrate_from_kde3_icon_theme) to migrate away
    from old KDE 3 icon themes which are KDE 4 incompatible (e.g. crystalsvg).
    (Closes: #588374)

 -- Modestas Vainius <modax@debian.org>  Sat, 12 Feb 2011 21:14:55 +0200

kde4libs (4:4.4.5-2) unstable; urgency=low

  * Point debian/control Vcs fields to the new Git repository.
  * kdelibs5-data should break/replace kdelibs-data 4:3.5.10.dfsg.1-4 as well.
    That version still has the same files as kdelibs5-data.

 -- Modestas Vainius <modax@debian.org>  Fri, 26 Nov 2010 21:46:06 +0200

kde4libs (4:4.4.5-1) unstable; urgency=low

  [ Modestas Vainius ]
  * New upstream release.
  * Bump KPluginLoader and libplasma3 symbol versions to 4:4.4.4-2~.

  [ Sune Vuorela ]
  * mkstemps is now provided by libc, stop providing it in kdecore as
    well
  * Update email address.
  * Add vietnamese debconf translations. Thanks to Clytie Siddall.
    (Closes: 576144)

 -- Sune Vuorela <sune@debian.org>  Sat, 17 Jul 2010 22:41:52 +0200

kde4libs (4:4.4.4-2) unstable; urgency=high

  * Improve 10_make_libkdeinit4_private.diff patch:
    - fix kpluginloader.cpp:findLibraryInternal() to find moved libkdeinit4_*s.
      This should reenable kxkb flag in lock dialog (Closes: #584870);
    - set R(UN)PATH for kdeinit executables only when LIBKDEINIT_INSTALL_DIR is
      not in implicit link directory list;
    - extend absolute exe path resolution to libkdeinit4_*s in the kdeinit4
      daemon.
  * Replace 09_disable_usr_lib_install_rpath.diff with a less extreme version
    of the patch from kde4libs trunk which should keep support for
    custom prefix builds (Closes: #586512).
  * Relax KDE version check when loading plugins. This enables plugins compiled
    against newer kde4libs to work with older kde4libs at runtime as well
    (Closes: #585792). The patch covers KPluginLoader and plasmoids.
  * Urgency=high to get this into testing before 4.4.5 (see #585792).

 -- Modestas Vainius <modax@debian.org>  Wed, 23 Jun 2010 00:27:20 +0300

kde4libs (4:4.4.4-1) unstable; urgency=low

  * New upstream release.

  [ Modestas Vainius ]
  * Drop pkg-kde-tools from kdelibs5-dev Depends. Add it as versioned Breaks
    instead.
  * Bump pkg-kde-tools build dependency to (>= 0.9) for HTML_INSTALL_DIR
    switch and 3.0 (quilt) source format support.
  * Switch to 3.0 (quilt) source package format and original tar.bz2
    tarballs.
  * Add debian/NEWS about HTML_INSTALL_DIR switch and pkg-kde-tools drop from
    kdelibs5-dev Depends.
  * Replace usr/share/doc/kde4 references with usr/share/doc/kde.
  * Rename 28_find_kde3_html_documentation.diff to
    28_find_old_kde4_html_documentation.diff and modify it to look in the
    /usr/share/doc/kde4/HTML (old HTML_INSTALL_DIR default).
  * Drop quilt from Build-Depends, no longer needed for 3.0 (quilt).
  * Drop patch system stuff from debian/README.source. Patch support is part of
    source format now.
  * Drop 00_4.4.3_final_tarball.diff patch, it was stolen from upstream.
  * Add 30_kfileshare_kdesu_fileshareset.diff patch to run libexec/fileshareset
    with kdesu rather than expect it (perl script) to be suid root.

  [ Pino Toscano ]
  * Fix typo in description of kdelibs-bin. (Closes: #582433)

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 01 Jun 2010 01:15:11 +0300

kde4libs (4:4.4.3-2) unstable; urgency=medium

  [ Modestas Vainius ]
  * Confirm symbol files for 4.4.3 on all arches except alpha.
  * Restore kdelibs5-dev installability with libkwebkit-dev (>= 0.9svn1123738).
  * Bring our 4.4.3 up-to-date with final upstream 4.4.3 tarball
    (patch 00_4.4.3_final_tarball.diff).
  * Urgency=medium as this upload is needed to get kdenetwork with security
    fix in.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 16 May 2010 22:30:03 +0300

kde4libs (4:4.4.3-1) unstable; urgency=low

  * New upstream release.

  [ Kai Wasserbäch ]
  * Update German Debconf translation. Thanks to Holger Wansing and Helge
    Kreutzmann. (Closes: #574015)

  [ Modestas Vainius ]
  * Update symbol files for 4.4.2 on hurd-i386 ia64 kfreebsd-amd64
    kfreebsd-i386 mips powerpc s390 sparc.
  * Release KDE SC 4.4.3 to unstable.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 01 May 2010 23:37:53 +0300

kde4libs (4:4.4.2-1) experimental; urgency=low

  * New upstream release.

  [ Modestas Vainius ]
  * Update patches:
    - drop 26_fixmanpage.diff - fixed upstream;
    - drop 30_fix_attica_includes.diff - merged upstream;
    - refresh other patches.
  * Update install files.
  * Move misplaced org.kde.kcontrol.kcmremotewidgets.service from kdelibs5-dev
    to kdelibs5-data, add appropriate replaces.
  * Update symbol files.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 05 Apr 2010 16:21:09 +0300

kde4libs (4:4.4.1-1) experimental; urgency=low

  * New upstream release:
    - kio_http_cache_cleaner does not causes trashing anymore.
      (Closes: #401561)
    - "three stars" password line edits should work again. (Closes: #550866)
    - fixes crash on triple click in the katepart. (Closes: #564085)
    - Kate part now preserves highlighting mode on document reload.
      (Closes: #523477)

  [ Modestas Vainius ]
  * Change my email address to modax@debian.org in Uploaders field.
  * Fix Vcs-Browser URL.
  * Drop obsolete presubj.
  * Do not export libQtUiTools.a symbols in kjsembed library
    (25_ld_exclude_libs_qtuitools.diff).
  * Build depend on pkg-kde-tools 0.6.4 which:
    - enables LIBKDEINIT_INSTALL_DIR=/usr/lib/kde4/libkdeinit and
      ENABLE_LIBKDEINIT_RUNPATH by default;
    - has dh_movelibkdeinit which actually moves libkdeinit4_*.so to the
      private directory;
    - is capable of generating strict local library interdependencies by
      stealing debian/shlibs.local generation code from qt4-x11;
    - is capable of generating ${allLibraries} and ${kde43Libraries} substs.
  * Implement a framework for moving libkdeinit4_*.so to the private directory:
    (patch 10_make_libkdeinit4_private.diff).
  * Split kdelibs5 into separate library packages:
    - each public library gets its own package with a few exceptions;
    - remaining stuff moved from kdelibs5 to kdelibs5-plugins;
    - individual libraries no longer depend on kdelibs-bin, but
      kdelibs5-plugins does (Closes: #530522).
    - new kdoctools binary package with files installed from kdoctools/
      directory in the source tree;
    - add package splitting rules to README.source;
  * Add control substs ${allLibraryPackages} and ${kde43LibraryPackages}
    for use in kdelibs5-{dev,dbg} and kdelibs5 metapackage despectively.
  * Add ${perl:Depends} to Depends of kdelibs5-plugins, kdelibs5-data and
    kdoctools.
  * Do not set RPATH to /usr/lib by default (patch
    09_disable_usr_lib_install_rpath.diff) (Closes: #564146). Disallowed on
    Debian.
  * Fix version in kdelibs5-data.NEWS (thanks to lintian).
  * Move "unsafe upgrade from KDE << 4.2.2" templates and handling to the
    kdelibs5-data package since kdelibs5 has become a metapackage and might be
    autoremoved during upgrade.
  * Add Breaks kdelibs5-data (<< 4:4.2.2) to kdelibs5, kdelibs5-plugins and
    libkdecore5 in order to force apt/aptitude/dpkg to unpack kdelibs5-data
    before them. kdelibs5-data is a lightweight package dependency wise.
  * Clean up lintian-overrides and add a couple of new ones.
  * Make /usr/share/kde4/apps/kconf_update/ksslcertificatemanager.upd.sh
    from kdelibs5-data executable.
  * Drop obsolete libplasma-dev provides from kdelibs5-dev.
  * Move kdewidgets.so and kde3supportwidgets.so to kdelibs5-dev.
  * Make kdelibs5-dev conflict with libkwebkit-dev.
  * Add symbol files for all public libraries (based on 4:4.3.4 where
    possible).
  * Inject unversioned kdebase-runtime dependency via a couple of libkdecore5
    and libkdeui5 symbols, which will be used by applications but typically not
    by libraries:
    - KCmdLineArgs in libkdecore5:
      - KCmdLineArgs::addCmdLineOptions();
      - KCmdLineArgs::addStdCmdLineOptions();
      - KCmdLineArgs::init() overloads;
    - KApplication in libkdeui5:
      - Constructors and destructors;
    - KUniqueApplication in libkdeui5:
      - Constructors and destructors;
  * Unversion kdebase-runtime injection via libkdecore5 shlibs.
  * Make libkdecore5 break kdebase-runtime (<< 4:4.4).
  * Move manual pages to the packages with their respective binaries.
  * Make kdelibs5-dbg replace kdebase-workspace-dbg (<< 4:4.4.0).
  * Move cmake from kdelibs5-dev Depends to Breaks.
  * Bump libphonon-dev in Build-Depends to 4:4.6.0really4.3.80.
  * Bump build dependency on dpkg-dev to 1.15.5.
  * Ship all_languages in kdelibs5-data (Closes: #556264).

  [ Kai Wasserbäch ]
  * debian/patches:
    - Drop backported patches:
      + 00_1034808_4.4_backport_rtldglobal.diff
    - Refresh and rework patches:
      + 08_add_debian_build_type.diff
      + 11_default_kde4_xdg_menu_prefix.diff
      + 14_hardcode_ptm_device.diff
      + 15_kfreebsd_support.diff
      + 17_findservicebydesktoppath_try_realfilepath.diff
      + 19_findqt4_optional_x11_pthread.diff
      + 20_use_dejavu_as_default_font.diff
      + 23_solid_no_double_build.diff
      + 25_ld_exclude_libs_qtuitools.diff
  * debian/control:
    - Add Build-Depends on libattica-dev, shared-desktop-ontologies,
      libpolkit-qt-1-dev, libxss-dev and libqca2-dev.
    - Bump Build-Depends for Qt to >= 4.6.0.
    - Bump Build-Depends for Phonon to >= 4.4.0.
    - Bump Build-Depends for libsoprano-dev to >= 2.4.0.1-2~.
    - Bump Standards-Version to 3.8.4, no further changes needed.
  * debian/kdelibs5-data.install: Update.

  [ George Kiagiadakis ]
  * Bump kdebase-runtime recommends to >= 4.4.
  * Add new packages for the new libraries shipped:
    libkdewebkit5, libknewstuff3-4, libkunitconversion4, libnepomukquery4a.
  * Add replaces: kdelibs5-dev replaces kdebase-workspace-dev << 4:4.4.0
    because the libnepomukquery headers were moved.

  [ Karl Ferdinand Ebert ]
  * update German translation.

  [ Pino Toscano ]
  * Add patch 29_hurd_support.diff to hopefully fix (even if not in the most
    elegant way) the compilation on GNU/Hurd.
  * Replace unused libtiff4-dev build-depend with zlib1g-dev and libjpeg-dev.
  * Update patch 13_qt4_designer_plugins_path.diff to fix the installation path
    of the kde3supportwidgets.so designer plugin.
  * Set the minimum version (either for build and runtime) of shared-mime-info
    to 0.30, as also upstream requires.

  [ Sune Vuorela ]
  * Add patch to change a include to a forward declaration to avoid exposing
    attica-headers to the world. Note that this makes us slightly source
    incompatible with the rest of the world, but actually it just exposes
    missing includes in other places.

  [ Ferdinand Thommes ]
  * Added missing copyrightholders to the respective sections.
  * Added new sections for kdewebkit and kunitconversion.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Thu, 11 Mar 2010 12:40:06 +0200

kde4libs (4:4.3.4-3) unstable; urgency=medium

  * Add -ffunction-sections to C(XX)FLAGS on ia64 in order to fix FTBFS.

 -- Modestas Vainius <modax@debian.org>  Fri, 19 Feb 2010 09:44:22 -0700

kde4libs (4:4.3.4-2) unstable; urgency=emergency

  * Fix libplasma3 symbols file (Closes: #570041).
  * Pass CMAKE_SKIP_RPATH=ON to cmake.
  * Urgency=emergency - needed for transition.

 -- Modestas Vainius <modax@debian.org>  Thu, 18 Feb 2010 15:19:16 +0200

kde4libs (4:4.3.4-1) unstable; urgency=low

  * New upstream release.
    - includes proper fixes for khtml show hide issue. (Closes: 553288)

  +++ Changes by George Kiagiadakis:

  * Add patch to make konsole work on GNU/kFreeBSD.

  +++ Changes by Xavier Vello:

  * Add patch to find KDE3 documentation on khelpcenter4

  +++ Changes by Modestas Vainius:

  * Update debian/patches:
    - 01_r1032787_khtml_show_hide_fix - remove, taken from upstream;
    - 02_r1032185_threading_issues_in_klocale - remove, taken from upstream;
    - 08_add_debian_build_type - refresh, offsets adjusted;
    - 14_hardcode_ptm_device - refresh, offsets adjusted;
    - 15_kfreebsd_support - refresh, offsets adjusted;
    - 20_use_dejavu_as_default_font - refresh, offsets adjusted;
  * Update libplasma3 symbols file.
  * Update install files.
  * Remove obsolete information from README.Debian. Add notes
    for people upgrading from Lenny to Squeeze regarding KDEHOME change.
  * Backport a patch from KDE 4.4 to make it possible to use kstyle plugins
    with RTLD_GLOBAL. Unbreaks openoffice.org (Closes: #550905) (patch
    00_1034808_4.4_backport_rtldglobal.diff, kde4libs part).

  +++ Changes by Pino Toscano:

  * Add liblzma-dev build-depend to add XZ support in kdecore.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Remove myself from Uploaders.

  +++ Changes by Christian Perrier:

  * Debconf templates and debian/control reviewed by the debian-l10n-
    english team as part of the Smith review project. Closes: #553451

  [Debconf translation updates]
  * Swedish (Martin Ågren).  Closes: #554453
  * Basque (Piarres Beobide).  Closes: #554560
  * Galician (Marce Villarino).  Closes: #555454
  * Bokmål, Norwegian (Bjørn Steensrud).  Closes: #555654
  * Czech (Tomas Fidler).  Closes: #555983
  * Italian (Vincenzo Campanella).  Closes: #556039
  * Spanish (Francisco Javier Cuadrado).  Closes: #556447
  * Russian (Yuri Kozlov).  Closes: #556547
  * Finnish (Esko Arajärvi).  Closes: #556795
  * Portuguese (Pedro Ribeiro).  Closes: #556848
  * Japanese (Hideki Yamane (Debian-JP)).  Closes: #557095

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 09 Dec 2009 00:24:08 +0200

kde4libs (4:4.3.2-2) unstable; urgency=low

  +++ Changes by Sune Vuorela:

  * Fix default monospace font name. Thanks Andrea Iacovitti. Closes: #549308.
  * Add patch from upstream to fix handling of deletion in khtml.
  * Add patch from upstream to fix a threading issue in klocale.

 -- Sune Vuorela <debian@pusling.com>  Sat, 10 Oct 2009 21:58:43 +0200

kde4libs (4:4.3.2-1) unstable; urgency=low

  * New upstream release.

  +++ Changes by Karl Ferdinand Ebert:

  * Modify kdelibs5.templates to conform partially with lintian complaints.
  * Add po-debconf and a first german translation.
  * Change UNRELEASED to experimental in kdelibs5-data.NEWS.
  * Add 26_fixmanpage.diff to adjust line break in FindBlitz.cmake.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 06 Oct 2009 14:59:23 +0200

kde4libs (4:4.3.1-1) unstable; urgency=low

  * New upstream release.

  +++ Changes by Fathi Boudra:

  * Add libutempter-dev build dependency. Used by kpty.

  +++ Changes by Modestas Vainius:

  * Remove 01_r1012564.diff patch, merged upstream.
  * Refresh patches.
  * Update kdelibs5-data.install.
  * Update libplasma3.symbols.in.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 29 Aug 2009 10:28:49 +0300

kde4libs (4:4.3.0-2) unstable; urgency=medium

  * Add patch: 01_r1012564.diff: Fixes a data loss with KIO.
  * Bump Standards-Version to 3.8.3 - no changes needed.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sat, 22 Aug 2009 13:32:44 +0200

kde4libs (4:4.3.0-1) unstable; urgency=low

  * New upstream release.
    - Disables kmail debug output by default (Closes: #537331).

  +++ Changes by Modestas Vainius:

  * Drop 09_disable_debug_messages_if_not_explicitly_enabled.diff patch - no
    longer needed.
  * Bump soprano build depends to 2.3.0.
  * New build dependencies:
    - flex - needed to build the Solid predicate parser;
    - bison - needed to build the Solid predicate parser.
  * Bump Standards-Version to 3.8.2 - no changes needed.
  * Update install files.
  * Update plasma symbols file, port it to dpkg-dev 1.15.3 compatible format
    and add build depend on dpkg-dev >= 1.15.3.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 04 Aug 2009 09:15:47 +0200

kde4libs (4:4.2.96-1) experimental; urgency=low

  * New upstream release candidate 2.

  +++ Changes by George Kiagiadakis:

  * Refresh patches.
  * Bump build dependency on Qt4 to version 4.5.1.
  * Bump build dependency on automoc to version 1.0~version-0.9.88.
  * Bump build dependency on soprano to version 2.1.68.
  * Remove patch 24_runtime_qt45_locale_initialization.diff as
    we now build-depend on Qt 4.5.
  * Update installed files.
  * Add myself to uploaders.
  * Update replaces: kdelibs-dev replaces kdebase-runtime-data (<< 4.2.90).
  * Update RUNTIME_DEPS variable in debian/rules to point to
    kdebase-runtime (>= 4.2.95).
  * Update recommends: kdelibs5 recommends kdebase-runtime (>= 4.2.95).
  * Add replaces: kdelibs5-dev replaces kdebase-workspace-dev (<< 4.2.90)
    because a cmake file (create_exe_symlink.cmake) was moved.
  * Update lintian overrides.

  +++ Changes by Sune Vuorela:

  * Make kdelibs break kdebase-workspace-bin.
  * Insntall files

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Fri, 26 Jun 2009 14:58:06 +0300

kde4libs (4:4.2.4-1) unstable; urgency=low

  * New upstream release:
    - Backport revert of auto-default button change to KDE 4.2.
      (Closes: #525561, #523744)

  +++ Changes by Modestas Vainius:

  * Fix typo in the kdelibs5.templates.

  +++ Changes by Sune Vuorela:

  * Fix sections.
  * Add Suggests: hspell to kdelibs5 for hebrew spell checking.

  +++ Changes by David Palacio:

  * Reword of kdelibs5.templates.

  +++ Changes by Fathi Boudra:

  * Update libplasma3.symbols.in file.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Fri, 01 May 2009 12:36:12 +0200

kde4libs (4:4.2.2-2) unstable; urgency=low

  +++ Changes by Modestas Vainius:

  * Move debconf to Pre-Depends.
  * Upgrade kaboom to kdelibs5 Recommends.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 06 Apr 2009 11:43:00 +0300

kde4libs (4:4.2.2-1) unstable; urgency=low

  * New upstream release.

  +++ Changes by Sune Vuorela:

  * Add aggressive conflicts to prevent mix and match.
  * Remove ban of upload of 3rd party apps.
  * Bump runtime versions.
  * Bump requirements of pkg-kde-tools to require the .kde edition.
  * Temporarily add a versioned dependency on pkg-kde-tools on kdelibs5-dev to
    be absolutely sure not having any accidents.
  * Add conflicts&replaces on kjscmd (Closes: 520453)

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Remove 01_kcmdlineargs_decoding_svn934640.diff, merged upstream.

  +++ Changes by Aurelien Jarno:

  * Update 15_kfreebsd.diff (Closes: #520123).

  +++ Changes by George Kiagiadakis:

  * Add patch 24_runtime_qt45_locale_initialization.diff to fix locale
    initialization when kde is run with Qt 4.5 but built with Qt 4.4.

  +++ Changes by Modestas Vainius:

  * Add debconf templates to warn existing KDE 4 users about KDEHOME change
    this revision introduces.
  * Add NEWS entry about KDEHOME change.
  * Bump libplasma symbol versions to 4:4.2.2.
  * Do not export QtUiTools symbols in libplasma.so.3
    (25_ld_exclude_libs_qtuitools.diff). Remove them from
    libplasma3.symbols.in. Should fix FTBFS on alpha.
  * kdelibs5 suggests kaboom.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 05 Apr 2009 05:33:47 +0300

kde4libs (4:4.2.1-2) unstable; urgency=low

  * Upload to unstable.

  +++ Changes by Fathi Boudra:

  * Add 01_kcmdlineargs_decoding_svn934640.diff patch from upstream
    to fix kcmdlineargs input decoding with Qt 4.5. (Closes: #518062)
    It contains also a fix from svn938370: use the new bool exported by Qt
    so that we can initialize the locale and make fromLocal8Bit/toLocal8Bit
    work even without a QCoreApplication.

  +++ Changes by Modestas Vainius:

  * Use dh_bugfiles and build depend on debhelper 7.2.3:
    - rename kdelibs5-dev.presubj to kdelibs5-dev.bug-presubj;
    - rename debian/libplasma3.bugscript to debian/libplasma3.bug-script.
  * Bump cmake build depend to 2.6.3. 24_2.6.2_use_common_cmake_config_dir.diff
    dropped.
  * Prepare for upload to unstable and ban unstable uploads of 3rd party
    packages (debian/ban-unstable-uploads & 24_ban_unstable_uploads.diff).

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Thu, 12 Mar 2009 13:53:37 +0100

kde4libs (4:4.2.1-1) experimental; urgency=low

  * New upstream release.

  +++ Changes by Modestas Vainius:

  * Remove patches which were stolen from upstream:
    - 01_r918838_kded_desktop_file_watch.diff
    - 00_917133_qreal_portability_fix.diff
    - 01_r918403_klauncher_hang.diff
    - 01_r918654_klauncher_unique_app.diff
    - 01_r917170_kio_update_on_break.diff
    - 00_917014_kde4.2.0_tag.diff
  * Point Debian Vcs URLs to pkg-kde/trunk (new location).

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Fri, 27 Feb 2009 17:59:21 +0200

kde4libs (4:4.2.0-3) experimental; urgency=low

  +++ Changes by Armin Berres:

  * Update patch 08_add_debian_build_type.diff to also set QT_NO_DEBUG and
    sync 09_disable_debug_messages_if_not_explicitly_enabled.diff with
    upstream revision 916186.

  +++ Changes by Modestas Vainius:

  * Update debian/libplasma3.symbols.in with {qreal} substitutions. Fixes
    FTBFS on arm(el).

  +++ Changes by Sune Vuorela:

  * Add patches from upstream for some stability fixed:
    01_r917170_kio_update_on_break.diff
    01_r918403_klauncher_hang.diff
    01_r918654_klauncher_unique_app.diff
    01_r918838_kded_desktop_file_watch.diff
    Thanks to David Faure for pushing them.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Thu, 29 Jan 2009 22:20:37 +0200

kde4libs (4:4.2.0-2) experimental; urgency=low

  +++ Changes by Modestas Vainius:

  * Tweak libplasma3 description.
  * Steal r917133 (as 00_917133_qreal_portability_fix.diff) from upstream svn
    to fix FTBFS on armel.
  * Deprecate external Qt symbols in libplasma3 symbols template
    (Closes: #513133).
  * Get up-to-date with kdelibs 4.2.0 tag: add 00_917014_kde4.2.0_tag.diff
    patch (plasma security issue).

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 27 Jan 2009 01:00:17 +0200

kde4libs (4:4.2.0-1) experimental; urgency=low

  * New upstream release.

  - kfmclient is no longer needed (Closes: #508601).

  +++ Changes by Modestas Vainius:

  * Resync patches:
    - 01_http_cache_cleaner_branch_881252.diff - remove, stolen from upstream.
    - 01_kross_version_11_r838337.diff - remove, stolen from unstream.
    - 08_add_debian_build_type.diff - refresh.
    - 13_qt4_designer_plugins_path.diff - refresh.
    - 14_hardcode_ptm_device.diff - refresh.
    - 15_kfreebsd_support.diff - refresh.
    - 16_debian_menu.diff - refresh.
    - 17_findservicebydesktoppath_try_realfilepath.diff - refresh.
    - 18_always_set_cmake_policy.diff - remove, obsolete.
    - 19_findqt4_optional_x11_pthread.diff - refresh.
    - 20_use_dejavu_as_default_font.diff - refresh.
    - 22_hack_in_etc_kde4_in_kstandarddirs.diff - refresh.
  * Update cmake (build-)dependency to 2.6.2:
    - depend on 2.6.2-3~ due to cmake common config lib support;
    - 23_2.6.2_use_common_cmake_config_dir.diff - enable support for common
      cmake config dir with cmake 2.6.2 (debian patched version);
    - enable cmake var KDE4_USE_COMMON_CMAKE_PACKAGE_CONFIG_DIR.
  * Build with -DCMAKE_USE_RELATIVE_PATHS=ON.
  * Bump standards-version to 3.8.0:
    - add README.source.
  * Cleanup old conflicts/replaces (for KDE 4.0 prerelease versions).
  * Add new packages for Plasma. They were based on the respective Plasma
    packages from kdebase-workspace.
    - libplasma3 - contains Plasma library and plugins. Make kdelibs5-dbg
      recommend it;
    - add Plasma headers to kdelibs5-dev, make it provide libplasma-dev,
      conflict and replace earlier libplasma-dev and recommend
      libqt4-opengl-dev needed to build GLapplet stuff;
    - kdelibs5-data replaces kdebase-workspace-data and libplasma2 from KDE 4.1
  * Update install and installgen files.
  * Make kdelibs5 recommend kdebase-runtime >= 4:4.1.80 because some
    stuff does not work (e.g. kwallet) with previous versions.
  * Build depend on strigi >= 0.6.3.
  * Move some libkdeinit4 stuff to kdelibs5 since their executables are in
    libexec:
    - libkdeinit4_klauncher.so
    - libkdeinit4_kio_http_cache_cleaner.so
    - libkdeinit4_kconf_update.so
  * Build depend on soprano >= 2.1.67.
  * Use better approach to enforcing kde4- prefix to applications.menu. The
    previous way broken menu spec and made 3rd party applications end up in
    Lost&Found menu. 11_kde4_applications_menu.diff patch was replaced by
    11_default_kde4_xdg_menu_prefix.diff. Thanks to Harald Sitter for the
    heads up.
  * Switch to new installgen file format.
  * Move upstream manpages from debian/*.manpages to debian/*.install files.
  * Build depend on pkg-kde-tools 0.3, add symbols file for libplasma3,
    add appropriate hooks to debian/rules.
  * kdelibs5-dev conflicts with kdepimlibs5-dev (<< 4:4.1.81+svn891439) because
    of upstream changes.
  * Rename debian/*.lintian to debian/*.lintian-overrides.
  * Bump debian/compat and debhelper build dependency to v7 (to get more
    sophisticated debian/tmp handling).

  +++ Changes by George Kiagiadakis:

  * Update automoc (build-)dependency to 1.0~svn850570.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Rework slightly patch 15_kfreebsd_support.diff.
  * Redo patch 20_use_dejavu_as_default_font.diff.
  * Force to build depend on libphonon-dev (>= 4:4.3.0).
  * Remove redudant section/priority fields in debian/control.
  * Update lintian overrides.
  * Update copyright years.

  +++ Changes by Armin Berres:

  * Fix patch 09_disable_debug_messages_if_not_explicitly_enabled.diff. Now
    really only debug output is disabled.
  * Add dependency on xdg-utils to kdelibs5. KDE applications use xdg-open to
    invoke a browser when not running in a KDE environment these days.

  +++ Changes by Sune Vuorela:

  * Copyright file updates. Thanks to Modestas and his magic scripts.
  * Remove plasma abi handling. It is expected to be stable now.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 24 Jan 2009 06:14:48 +0200

kde4libs (4:4.1.4-1) experimental; urgency=low

  * New upstream release.

  +++ Changes by Sune Vuorela:

  * shlibs bump.

  +++ Changes by Modestas Vainius:

  * Use better approach to enforcing kde4- prefix to applications.menu. The
    previous way broken menu spec and made 3rd party applications end up in.
    Lost&Found menu. 11_kde4_applications_menu.diff patch was replaced by
    11_default_kde4_xdg_menu_prefix.diff. Thanks to Harald Sitter for the
    heads up.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Fri, 09 Jan 2009 22:00:46 +0100

kde4libs (4:4.1.3-2) experimental; urgency=low

  +++ Changes by Modestas Vainius:

  * Bump kdebase-runtime dependency back to 4.1.3. The previous change was
    a mistake.
  * Bump kdelibs5 shlibs to 4.1.3-2 to ease the pain.

  +++ Changes by Sune Vuorela:

  * Add patch for http cache cleaner to keep the cache revision in sync.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Fri, 07 Nov 2008 22:18:05 +0200

kde4libs (4:4.1.3-1) experimental; urgency=low

  * New upstream release

  +++ Changes by Sune Vuorela:

  * Remove kdedglobalaccel crash patch. Merged upstream.

  +++ Changes by Modestas Vainius:

  * Bump shlibs to 4.1.3.
  * Loosen kdebase-runtime dependency back to 4.1.0. There seems to be no
    other easy way to solve experimental buildd failures. This should not
    hurt too much.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 04 Nov 2008 09:56:56 +0200

kde4libs (4:4.1.2-2) experimental; urgency=low

  * Fix kdedglobalaccel crashes. Patch 02.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sun, 12 Oct 2008 20:00:14 +0200

kde4libs (4:4.1.2-1) experimental; urgency=low

  * New upstream release.
  * Update UPSTREAMVERSION to 4.1.2 in debian/rules.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sun, 28 Sep 2008 12:33:31 +0200

kde4libs (4:4.1.1-1) experimental; urgency=low

  * New upstream release.

  +++ Changes by Sune Vuorela:

  * Update patches;
    - remove 01_r840377_840379_unload_on_close.diff merged upstream
    - remove 02_41branch_link_interface_libraries.diff.
    - remove 99_conservative_link_interface_libraries.diff, no need to be more
      conservative than upstream.
  * Add new file FindEigen2.cmake in kdelibs5-dev.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 02 Sep 2008 00:22:08 +0200

kde4libs (4:4.1.0-3) unstable; urgency=low

  +++ Changes by Fathi Boudra:

  * Update kross to version 11 (r838337). Fix build of latest kdevplatform
    and kdevelop4 (Closes: #491272).

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 26 Aug 2008 18:56:06 +0200

kde4libs (4:4.1.0-2) unstable; urgency=low

  +++ Changes by Modestas Vainius:

  * Add 01_r840377_840379_unload_on_close.diff patch.
    Fixes a nasty bug which makes some KDE4 apps stay in memory when closed
    resulting into excessive memory usage after some time.
  * Readd usr/share/man/man1/kdecmake.1 kdelibs5-dev.
  * Build depend on cmake >= 2.6.
  * Update automoc build-dependency.
  * Replace unofficial 90 patch with the one taken from KDE 4.1 branch.
    (02_41branch_link_interface_libraries.diff). It is the version "supported"
    by upstream with some extra features. It does not seem to be much different
    from the previous 90_ patch.
  * Add 99_conservative_link_interface_libraries.diff which *adds* some more
    LINK_INTERFACE_LIBRARIES to reduce linking failures of third party
    applications. This patch surely does not break anything, it only adds more
    libraries which are eliminated by --as-needed in Debian packaging.
    However, it might help to link a random KDE4 3rd party application against
    our kde4libs.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Rename debian/kdelibs5.bug-presubj to right filename debian/kdelibs5.presubj.
  * Replace libcupsys2-dev with libcups2-dev.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 06 Aug 2008 20:29:38 +0200

kde4libs (4:4.1.0-1) unstable; urgency=low

  * New upstream release 4.1.0.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Bump build depends to new versions of phonon and soprano.
  * Update UPSTREAMVERSION to 4.1.0 in debian/rules.
  * Keep build-depend on cmake >= 2.4.5, but force everything build depending
    on kdelibs5-dev use cmake 2.6.
  * Remove patch 98_link_interface_libraries, merged upstream.

  +++ Changes by Modestas Vainius:

  * Adapt kdelibs5-dev deps to new dh_sameversiondeps syntax.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Fri, 25 Jul 2008 21:08:49 +0200

kde4libs (4:4.0.98+svn833207-1) unstable; urgency=low

  * New upstream snapshot.

  +++ Changes by Modestas Vainius:

  * Do not require cmake 2.6 (kdelibs5-dev).

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Remove patch 01, merged upstream.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 16 Jul 2008 15:17:41 +0200

kde4libs (4:4.0.98-2) unstable; urgency=medium

  * Add patch 01_ to add missing LGPL entity needed to build french
    translations.
  * Remove kdelibs5-doc package for now. (Closes: #464396)

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Tue, 15 Jul 2008 14:11:23 +0200

kde4libs (4:4.0.98-1) unstable; urgency=low

  * New upstream release, Release Candidate 1.

  +++ Changes by Sune Vuorela:

  * Yay. Now Debian menu items in Debian menu instead of in Lost & Found.
  * Remove deprecate applnk patch. It is already deprecated, no need for the
    patch. It only removes legacy handling.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Do not install kdecmake.1 because it is not created when building in hppa
    with cmake 2.4.8. (Closes: #488661)

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 14 Jul 2008 01:10:40 +0200

kde4libs (4:4.0.84+svn828328-1) unstable; urgency=low

  * New upstream development snapshot.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Remove patches 97_use_imported_targets_with_cmake26.diff and
    99_more_implicit_link_libs.diff
  * Update 98_link_interface_libraries.diff
  * Add 90_reduce_linking.diff by A. Neundorf.

  +++ Changes by Armin Berres:

  * Disable debug output of KMail by default.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 05 Jul 2008 18:48:48 +0200

kde4libs (4:4.0.84-1) experimental; urgency=low

  * New upstream snapshot.

 -- Sune Vuorela <debian@pusling.com>  Fri, 27 Jun 2008 19:19:33 +0200

kde4libs (4:4.0.82+svn819867-1) experimental; urgency=low

  * New upstream development snapshot.

  +++ Changes by Armin Berres:

  * Add libxcursor-dev build dependency.
  * Recommend the new default font ttf-dejavu.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Remove phonon package stuff, it has been split out from kde4libs.
  * Add build depends on phonon-dev.
  * Update UPSTREAMVERSION in debian/rules.
  * Update installed files.
  * Add Conflicts with libkjsembed-dev from KDE 3 to kdelibs5-dev.
    (Closes: #480686)

  +++ Changes by Modestas Vainius:

  * Drop 18_always_set_cmake_policy.diff patch - applied upstream.
  * Make kdelibs5-dev depend on libphonon-dev, KDE4Internal.cmake REQUIRES it.
  * Bump shlibs to 4.0.82.
  * Exclude dependancy on phonon metapackage.

  +++ Changes by Sune Vuorela:

  * Install config files in /usr/share/kde4/config.
  * Patch kstandarddirs to look in home, installpath, prefix/path except when
    config files, where home, /etc/kde4, prefix/path, installpath is
    preferred. Patch developed in cooperation with Fedora. (Closes: #484897).
  * Add README file about the configuration stuff.
  * Versioned build-dep on shared-mime-info.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 14 Jun 2008 00:05:51 +0300

kde4libs (4:4.0.80-1) experimental; urgency=low

  * New upstream development milestone (KDE 4.1 Beta1).

  +++ Changes by Modestas Vainius:

  * Disable 97 patch (will be removed later).
    Pass -DKDE4_ENABLE_EXPERIMENTAL_LIB_EXPORT=on to cmake which enables
    equivalent functionality.
  * Update install files.
    - Add makekdewidgets.1 man page to kdelibs5-dev.
    - Move checkXML.1 from kdelibs5-data to kdelibs5-dev. Bump replaces.
  * Refresh patches.
  * Ligthen cmake build-dependency to 2.4.5.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 21 May 2008 22:53:51 +0300

kde4libs (4:4.0.74-1) experimental; urgency=low

  * New upstream snapshot.
  * Raise the added shlibs dependency for kdebase-runtime to 4:4.0.72.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 17 May 2008 17:41:23 +0200

kde4libs (4:4.0.73+svn806390-1) experimental; urgency=low

  * New upstream development snapshot:
    - The latest upstream commit is r806390 by uwolfer
    - Date: Sun, 11 May 2008 10:32:27 -0000

  * Corrections to *.install files:
    - kdelibs5-dev.install: 1 new file(s) added;
    - kdelibs-bin.install: 1 file(s) removed;

  +++ Changes by Modestas Vainius:

  * Add libacl1-dev to build depends.
    Refresh 98 patch (kio_file build failure).
  * Allow to set UPSTREAMVERSION in the environment.
  * Use external automoc. Build-depend on automoc (>= 1.0~svn805317), make
    kdelibs5-dev depend on it too.

  +++ Changes by Armin Berres:

  * kdelibs5-dev must replace kdelibs-data << 4:4.0.72-1 after the move of the
    dbus-1 XML interfaces.

  +++ Changes by Fathi Boudra:

  * Add 20 patch to use DejaVu font as default font.
  * Add libxml2-utils dependency to kdelibs-bin: meinproc4 needs it.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 11 May 2008 13:51:16 +0300

kde4libs (4:4.0.72-1) experimental; urgency=low

  * New upstream snapshot. (r802761)

  * Fixes heap based buffer overflow via specially encoded image.
    CVE-2008-1670 (Closes: #478283)

  +++ Changes by Modestas Vainius:

  * 98_link_interfaces_library.diff - major update:
    - Drop ${QT_QTNETWORK_LIBRARY}, ${QT_QTDBUS_LIBRARY}, ${QT_QTXML_LIBRARY}
      from kdecore LINK_INTERFACE_LIBRARIES leaving only ${QT_QTCORE_LIBRARY}.
      Those 3 libraries are no longer implicitly provided by any kdelibs
      target. This may cause a few link time FTBFSes.
    - Further update LINK_INTERFACE_LIBRARIES of other public libraries.
  * Export ${KDE4_THREADWEAVER_LIBRARIES} and an alias for
    ${KDE4_THREADWEAVER_LIBS} to restore compatibility.
  * Fix offsets in other patches so they apply cleanly.
  * Move usr/include/KDE/Phonon from kdelibs5-dev to libphonon-dev. Update
    *.install files and Replaces for libphonon-dev appropriately.
  * Enhance 19_findqt4_optional_x11.diff patch. Do not implicitly add
    -lphread.
  * Build depend on libenchant-dev.
  * Add 99_more_implicit_link_libs.diff which adds more implicit link
    interface libraries to diverge from upstream as least as possible.
    - In addition, kdecore implies QtDBus, QtXml, QtNetwork.
    - In addition, kdeui implies QtSvg.
    - In addition, kde3support and ktuils imply kparts.
    - In addition, kio implies solid.
  * Move dbus-1 XML interfaces to kdelibs5-dev.install.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 30 Apr 2008 18:03:58 +0200

kde4libs (4:4.0.70+svn799089-2) experimental; urgency=low

  +++ Changes by Modestas Vainius:

  * Export kparts as khtml interface library.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 21 Apr 2008 20:22:47 +0300

kde4libs (4:4.0.70+svn799089-1) experimental; urgency=low

  * New upstream development snapshot:
    - The latest upstream commit is r799089.

  +++ Changes by Armin Berres:

  * Update and sort *.install files.

  +++ Changes by Ana Beatriz Guerrero Lopez

  * Add new build depends after Qt4 have updated its build depends:
    libpng-dev, libssl-dev, libsm-dev.
  * Add version to the RUNTIME_DEPS in debian/rules.

  +++ Changes by Modestas Vainius:

  * New version of 17_findservicebydesktoppath_try_realfilepath.diff. Still
    incomplete.
  * Shrink *-dev dependency list of kdelibs5-dev to libqt4-dev (>= 4.4.0~),
    libsoprano-dev (>= 2.0.97~). Thanks to Sune Vuorela for determining this
    set from #include's of the public headers.
  * Add 18_always_set_cmake_policy.diff patch to set CMake policy settings
    regardless of KDE_FOUND value.
  * Introduce 97_use_imported_targets_with_cmake26.diff which changes the way
    libraries dependences are exported when built with CMake 2.6:
    - Rationale behind this is to reduce excess linkage.
    - Build-depend on cmake 2.6 or later. Make kdelibs5-dev depend on
      cmake 2.6.
    - Do not use export_library_dependencies() to export library dependences
      with CMake 2.6. This method was the main source of excess linkage
      problems. Use a brand new install(EXPORT) instead which supports
      LINK_INTERFACE_LIBRARIES.
    - Due to the change above, add "EXPORT kdelibs" property for all public
      install(TARGETS).
    - Rewrite the part of FindKDE4Install.cmake which deals with
      KDE4_*_LIBRARY and KDE4_*_LIBS setup. Since we are using cmake IMPORTED
      targets now and let cmake do a major part of dependency handling for us,
      make each KDE4_*_LIBS variable refer to the IMPORTED target of the
      respective public KDE library. KDE4_*_LIBRARY semantics were not changed
      and they still point to the result of find_library().
  * Add 98_link_interface_libraries.diff which:
    - Tweaks target_link_libraries() calls where dependences where were
      missing.
    - Makes use of LINK_INTERFACE_LIBRARIES target property to control which
      libraries are exported via link interface (property values probably need
      more tweaking). This is CMake 2.6 or only, ignored for CMake 2.4.
  * Make kdelibs shlibs "dynamic" and ensure kdebase-runtime from KDE 4.1
    series is used as runtime dependency.
  * Build-depend on libglu1-mesa-dev as libqt4-dev 4.4.0~rc1-5 is dropping it
    from Depends.
  * Add myself to Uploaders.
  * Add 19_findqt4_optional_x11.diff - make X11 optional for in FindQt4.cmake.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 20 Apr 2008 22:12:38 +0300

kde4libs (4:4.0.68+svn794641-1) experimental; urgency=low

   * New upstream development snapshot.

   +++ Changes by Modestas Vainius:

   * Sort *.install files
   * Drop 16_postgresql_include_path_fix.diff - merged upstream.
   * Add 17_findservicebydesktoppath_try_realfilepath.diff to improve
     desktop file location by path on the systems where e.g. /usr is a
     symlink. Please note this patch still does not fix what I developed
     it for. So it's useless but it does not hurt. Work in progress.
  * Add Replaces: kdebase-runtime-data << KDE 4.1 for kdelibs5-dev due to
    common file /usr/share/kde4/apps/cmake/modules/FindXine.cmake

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Tighten build depend version on libstreamanalyzer-dev 0.5.8-2
    from experimental.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sun, 06 Apr 2008 22:12:02 +0300

kde4libs (4:4.0.66+svn791114-1) experimental; urgency=low

  * First KDE 4.1 snapshot packaged, this is going to experimental.
  * Update installed files.
  * Refresh and update patches.
  * Bump to new version number where needed.
  * Add some versioned depends on Qt4 4.4.
  * Replace libqt4-debug with libqt4-dbg.
  * Build depend on soprano >= 2.0.97~.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Fri, 28 Mar 2008 13:36:21 +0100

kde4libs (4:4.0.2-1) unstable; urgency=low

  * New upstream release.

  +++ Changes by Armin Berres:

  * Don't bump shlibs version automatically on every upload. Bumping on new
    upstream versions is enough now that the libs are stable.
  * Add versioned shlibs to libphonon4.
  * Remove kde-icons-oxygen and kdebase-runtime-data from the shlibs file of
    kdelibs5. kdebase-runtime depends on them anyway.
  * Add strict dependency of kdelibs-bin on kdelibs5 and use a more obvious
    way to remove the dependency on kdebase-runtime. shlibs.local is no more
    needed now.

  +++ Changes by Matthew Rosewarne:

  * Build-Depend on libgif-dev instead of libungif4-dev.

  +++ Changes by Modestas Vainius:

  * New patch 16_postgresql_include_path_fix.diff, which adds PostgreSQL
    include paths used on Debian to FindPostgreSQL cmake module.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Drop patches pulled from KDE's SVN, now part of the release
    - 01_make_stackingOrder_work_r769072.diff
    - 02_re-register_global_shortcuts_r769363.diff
  * Update installed files.
  * Update UPSTREAMVERSION in debian/rules.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Tue, 04 Mar 2008 12:52:59 +0100

kde4libs (4:4.0.1-1) unstable; urgency=low

  * New upstream release.

  +++ Changes by Matthew Rosewarne:

  * Make dependencies binNMU-friendly.
  * Bump Soprano minimum version to 2.0.0.
  * Remove redundant Depends: shared-mime-info from kdelibs5-dev.
  * Add Suggests: kdelibs5-doc to kdelibs5-dev.

  +++ Changes by Armin Berres:

  * Update 10_kdehome_kde4 patch. Set kde home directory to ~/.kde4
    where ~/.kde was used. Thanks to Jonathan Riddell and Suse people.
  * Update installed files.
  * Drop no more needed patch 16_arm_fixes.diff.

  +++ Changes by Fathi Boudra:

  * Make kdelibs5-dev installable on GNU/kFreeBSD. Thanks to Aurelien Jarno.
    (Closes: #462338)
  * Add dbus-x11 dependency to kdelibs5. Thanks to Chris Desjardins.
  * Add Vcs-Browser and Vcs-Svn fields.
  * Cherry pick from branches/KDE/4.0:

    + 02_re-register_global_shortcuts_r769363:
      Re-register global shortcuts if kded4 is restarted.

  +++ Changes by Adeodato Simó:

  * Cherry pick from /branches/KDE/4.0:

    + 01_make_stackingOrder_work_r769072: fix KWindowSystem::stackingOrder() to
      actually return a non-empty list with the list of windows.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Update to debhelper 6.
  * Add versioned b-d on cdbs (>= 0.4.51) to get debhelper 6 support and fixed
    cmake.mk class.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 04 Feb 2008 09:59:44 +0100

kde4libs (4:4.0.0-2) unstable; urgency=low

  +++ Changes by Fathi Boudra:

  * Update arm patch. Avoid conversion to float. Thanks to Pino Toscano.
  * Move hal and pmount Recommends to kdebase-runtime-bin-kde4 package.
  * Rename kdelibs-dbg to kdelibs5-dbg.
    Conflicts/Replaces against kdelibs-dbg >= 4:3.91.0-1 and << 4:4.0.0-2

  +++ Changes by Armin Berres:

  * Add ${shlibs:Depends} dependency to kdelibs5-dev.

 -- Fathi Boudra <fabo@debian.org>  Sun, 13 Jan 2008 00:39:59 +0100

kde4libs (4:4.0.0-1) experimental; urgency=low

  * New upstream release. KDE 4.0.0 yay!

  +++ Changes by Armin Berres:

  * Add patch to disable debug information by default. They can be enabled
    with kdebugdialog.
  * Add patch to build no special debug code, but release code, and remove
    all hardcoded optimization and debug compiler flags. Use $(CXXFLAGS) and
    $(CFLAGS) instead.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Update patch 15_kfreebsd_support to build in kfreebsd after latest changes
    in ConfigureChecks.cmake.
  * Update lintian overrides.
  * Add patch to fix make it build in arm and hopefully armel. Thanks Aurel.
    (Closes: #459515)

  +++ Changes by Matthew Rosewarne:

  * Add Homepage: to control.
  * Tweak package descriptions.
  * Replace dependency on xbase-clients with xauth.
  * Replace source:Version with binary:Version.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 09 Jan 2008 06:19:10 +0100

kde4libs (4:3.98.0~svn755919-1) experimental; urgency=low

  * New svn snapshot release to revision 755919.

  +++ Changes by Fathi Boudra:

  * Build-dep on soprano >= 1.99~rc2-1. (Closes: #458334)
  * Split kdelibs5-dev and kdelibs. Move Phonon in his own packages.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Fix offsets in 15_kfreebsd_support patch.
  * Update years in debian/copyright. Happy new year!

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 02 Jan 2008 14:08:10 +0100

kde4libs (4:3.98.0~svn753247-1) experimental; urgency=low

  * Svn snapshot of revision 753247.
  * Remove extra LDFLAGS. Included via CDBS now.
  * Update patches.
  * Update installed files.
  * Force runtime dependency on kdebase-runtime instead of the removed
    kdebase-runtime-bin.

 -- Armin Berres <armin+debian@space-based.de>  Thu, 27 Dec 2007 16:11:13 +0100

kde4libs (4:3.97.0-2) experimental; urgency=low

  * The "Pizza with Champagne" release.

  +++ Changes by Armin Berres:

  * Add patch to hardcode /dev/ptmx as ptm device to work around broken
    build environments.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Add patch for kfreebsd support.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Sat, 15 Dec 2007 03:31:22 +0100

kde4libs (4:3.97.0-1) experimental; urgency=low

  * New upstream release.
  * Update *.install files.
  * Update Standards-Version to 3.7.3.
  * Remove README.Debian, packages are stable now.
  * Update package descriptions, remove references to beta status.
  * Add export LDFLAGS+="-Wl,--as-needed" in rules to make dpkg-shlibdeps
    happier.
  * Do not build depend on libasound2-dev and libkeyutils-dev in the archs
    they do not exist.
  * Move Depends on hal | kfreebsd-gnu | hurd, pmount | kfreebsd-gnu | hurd,
    to Recommends. (Closes: #452255)
  * Add lintian override for extra-license-file warnings in kdelibs5-data.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sun, 09 Dec 2007 15:47:28 +0100

kde4libs (4:3.96.0-1) experimental; urgency=low

  * New upstream release.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Update *.install files.

  +++ Changes by Fathi Boudra:

  * Bump build dependencies versions.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Wed, 14 Nov 2007 13:17:32 +0100

kde4libs (4:3.95.0-1) experimental; urgency=low

  * New upstream release: KDE4 beta 4.

  +++ Changes by Fathi Boudra:

  * Remove libpulse0 conflict. It was a temporary workaround.
  * Update 11_applications_menu patch. We must keep the extension unchanged.
  * Add 12_deprecate_applnk patch. We use /usr/share/applications in any case.

  +++ Changes by Armin Berres:

  * Update *.install files.

  +++ Changes by Sune Vuorela:

  * Leet shlibs hacking.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Thu, 25 Oct 2007 14:47:24 +0200

kde4libs (4:3.94.0-2) experimental; urgency=low

  +++ Changes by Fathi Boudra:

  * Pull SVN branch to r726725.

  +++ Changes by Armin Berres:

  * Add debug package.
  * Make kdelibs5-dev depend on recent soprano.
  * Add dependency of kdelibs5 on kde-icons-oxygen. It is needed by nearly
    every KDE4 application.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * Update *.install files.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Thu, 18 Oct 2007 20:56:22 +0200

kde4libs (4:3.94.0-1) experimental; urgency=low

  * KDE4 beta3.

  +++ Changes by Armin Berres:

  * Add kdelibs5 dependency on shared-mime-info.
  * Update *.install files.
  * Install man pages.
  * Rename debian/no-install.txt to debian/not-installed and reformat it for
    being usable with "debian/rules list-missing".
  * Update patches.
  * Depend on up to date libsoprano.
  * Conflict with libpulse0 for preventing crashes. This is definitely just a
    temporary workaround and should be removed ASAP.
  * Depend on hal which is used as Solid backend.
  * Depend on pmount.

  +++ Changes by Sune Vuorela:

  * kjscmd also exists in kjscmd from kdebindings. Adding conflict.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Wed, 17 Oct 2007 13:42:50 +0200

kde4libs (4:3.93.0-1) experimental; urgency=low

  * New upstream version.
   - Remove patches: 01_libkdeprint_management_soname and
     02_strigi-0.5.5_support merged upstream. And 12_no_emoticon is not
     longer needed.
  * Update *.install files.
  * Update not-installed.list
  * Remove prune-nonfree, there is not longer non-free stuff.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Sun, 03 Sep 2007 20:13:59 +0200

kde4libs (4:3.92.0.dfsg.1-2) experimental; urgency=low

  +++ Changes by Fathi Boudra:

  * Add patch to support strigi-0.5.5.
  * Move binaries to kdelibs5-dev:
    * checkXML, kconfig_compiler, ksvgtopng, kunittestmodrunner,
      makekdewidgets, preparetips.
  * Add kdelibs5-dev conflicts against kdelibs4-dev.
  * Remove qt4-designer-kde4-plugins package. No need to have an extra package
    as qt4 designer plugins are higky dependent on kdelibs5 and development.
  * Add qt4_designer_plugins_path patch to fix plugins installation path.

  +++ Changes by Ana Beatriz Guerrero Lopez:

  * No shipping emoticons images to avoid conflicts with current kdebase-data
    (KDE3), patch 12. See list in no-install.list.
  * Add patch 04_libkdeprint_management_soname.diff to avoid same soname name
    than in current KDE version.
  * Build-Depend only on libungif4-dev. kdegraphics b-d on imlib11 that b-d on
    libungif4-dev, if we build against libgif-dev, this kdelibs version and
    kdegraphics3 can not co-exist.

 -- Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>  Mon, 13 Aug 2007 02:21:33 +0200

kde4libs (4:3.92.0.dfsg.1-1) experimental; urgency=low

  * KDE4 beta 1, first upload to the Debian archive.
  * Update *.install files.
  * Prune non-free files, added script prune-nonfree.
  * Add patches:
    * 01_kdehome_kde4: set kdehome directory to .kde4.
    * 02_applications_menu_kde4: append .kde4 to applications.menu.
  * Add warning about experimental packages in README.Debian.
  * Remade the copyright file, thanks to  Marc 'HE' Brockschmidt, for
    sharing the fun.

 -- Ana Beatriz Guerrero Lopez <ana@debian.org>  Mon, 06 Aug 2007 16:38:29 +0200
Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2017 FileWatcher.com