Filewatcher File Search File Search
Catalog
Content Search
» » » » » libopenobex1-dev_1.3-3_amd64.deb » Content »
pkg://libopenobex1-dev_1.3-3_amd64.deb:58278/usr/share/doc/libopenobex1-dev/  info  control  downloads

libopenobex1-dev - OBEX protocol library - development files…  more info»

changelog.Debian.gz

libopenobex (1.3-3) unstable; urgency=low

  * do not install the libopenobex.la file, should resolve that sticking
    libusb dependency for packages that depend on libopenobex and use libtool
    (after being rebuilt)
  * use Requires.private instead of Libs.private in .pc file and adapt REQUIRES
    define to not include bluez
  * compile apps without libusb (not needed)
  * debian/control: build depend on automake-1.9, autoconf and libtool
  * debian/rules: run autoreconf where appropriate

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Fri, 29 Sep 2006 01:03:52 +0200

libopenobex (1.3-2) unstable; urgency=low

  * add pkgconfig.patch: fixes pkg-config output for dynamic linking

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Tue, 26 Sep 2006 23:22:52 +0200

libopenobex (1.3-1) unstable; urgency=low

  * New upstream version
  * Clean up debian/rules
  * Bump standards revision to 3.7.2.0: no changes required.
  * Update build dependencies:
    - update quilt version to 0.45
    - change from libbluetooth1-dev to libbluetooth2-dev, same for Depends field
      of binary package libopenobex1-dev (closes: #376900)
  * Fix quilt inclusion in debian/rules and roperly use quilt stamp file in the
    rules file
  * Remove patches that got applied upstream:
    - rodrigues_irobex_palm3.patch
    - docbuild.patch
    - obex_test.patch
  * Add new docbuild2.patch to fix building of documentation, again, because
    docbook2html fails with XML DOCTYPE declaration
  * Lower dependency from libopenobex1-dev on pkg-config from Depends to Suggests
    (it is a useful tool but the package can be used without it)

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Thu,  6 Jul 2006 02:07:56 +0200

libopenobex (1.2-3) unstable; urgency=low

  * The "fix some bugs after some years" release
  * Update ircp.patch to never overwrite existing files but
    rename the target name instead (closes: #366484)
  * Update rodrigues_irobex_palm3.patch to fix argument parsing
    (closes: #216312)
  * Add obex_test.patch to fix some issues with the test apps
    (closes: #197773). Note that the patch from the bug report
    was not plainly used.
  * Add manpages for all applications (closes: #253857)

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Fri, 12 May 2006 02:14:05 +0200

libopenobex (1.2-2) unstable; urgency=low

  * Fix Replaces/Conflicts with ircp (closes: #359061, #359201)
  * Fix version of debhelper build dependency
  * Add missing direct build dependency on docbook (closes: #359026)
  * use the quilt.make include:
    - tighten quilt build dependency
    - remove debian/quiltrc

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Fri,  7 Apr 2006 13:06:53 +0200

libopenobex (1.2-1) unstable; urgency=low

  * New upstream release (closes: #358375)
  * Change priority of -dev package to "extra"
  * Change default section to "comm"
  * Use debhelper compat level 5
  * move ircp to openobex-apps package
  * add quilt to build dependecies and do patching at build time

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Fri, 24 Mar 2006 09:18:17 +0100

libopenobex (1.1-1) unstable; urgency=low

  * New maintainer
  * New upstream release (closes: #237386)
    - supports USB
    - changes to pkgconfig
  * Change package name according to the libpkg-guide
  * Conflict with the old -dev package
  * Use quilt for patches (using debian/quiltrc)
  * Add docbuild patch to be able to build documentation
  * Include documentation in the -dev package
  * Package openobex-apps is not shipped seperately anymore, so include it
  * Package ircp is not shipped seperately anymore, so include it 
  * Update FSF address

 -- Hendrik Sattler <debian@hendrik-sattler.de>  Fri, 10 Feb 2006 12:41:46 +0100

libopenobex1.0 (1:1.0.0-rel-3) unstable; urgency=low

  * Acknowledge NMU.
  * Restored big-endian patch.
  * Add patch for obex_server.c to detect a read when object deleted.

 -- Edd Dumbill <ejad@debian.org>  Fri,  4 Jun 2004 00:51:04 +0100

libopenobex1.0 (1:1.0.0-rel-2.1) unstable; urgency=low
 
   * NMU if the maintainer does not react
   * Restored the Testing version with an epoched version because
     libopenobex1.0.1 is another library generation (closes: #214471)
	  
 -- Eduard Bloch <blade@debian.org>  Sun, 12 Oct 2003 15:49:25 +0200

libopenobex1.0 (1.0.1-1) unstable; urgency=low

  * New upstream release.
  * Changed section of libopenobex-dev to 'libdevel'
  * Remove big-endian patch: now incorporated upstream.

 -- Edd Dumbill <ejad@debian.org>  Mon,  6 Oct 2003 13:37:48 +0100

libopenobex1.0 (1.0.0-rel-2) unstable; urgency=low

  * Moved to Colin's Build System
  * Incorporate patch from CVS to fix Bluetooth use on big-endian
    systems (thanks Marcel Holtmann)

 -- Edd Dumbill <ejad@debian.org>  Sun, 23 Mar 2003 14:53:33 +0000

libopenobex1.0 (1.0.0-rel-1) unstable; urgency=low

  * New upstream release

 -- Edd Dumbill <ejad@debian.org>  Mon,  2 Dec 2002 20:22:01 +0000

libopenobex1.0 (1.0.0-pre5-1) unstable; urgency=low

  * Unreleased.
  * New upstream release (Closes: #167327)
    - supports Bluetooth transport layer
    - removes dependency on glib-1.2
  * Renamed packages as source & binary compatibility broken from earlier
    releases.  Used scheme as per Junichi Uekawa's library packaging
    guide.

 -- Edd Dumbill <ejad@debian.org>  Sun, 17 Nov 2002 17:51:25 +0000

libopenobex (0.9.8-7) unstable; urgency=low
 
  * Make openobex-config output includes and libs for bringing in
    the glib dependencies (Closes: #170090)
 
 -- Edd Dumbill <ejad@debian.org>  Thu, 21 Nov 2002 22:57:42 +0000
 
libopenobex (0.9.8-6) unstable; urgency=low
 
  * Fixed the .so files to be in the right packages
  * Updated standards version to 3.5.8
  * Added Section to the source description
 
 -- Edd Dumbill <ejad@debian.org>  Mon, 18 Nov 2002 01:50:22 +0000

libopenobex (0.9.8-5) unstable; urgency=low

  * New maintainer
  * Added shlibs file
  * Added simple manpage for openobex-config

 -- Edd Dumbill <ejad@debian.org>  Mon, 18 Nov 2002 00:33:25 +0000

libopenobex (0.9.8-4) unstable; urgency=low

  * Update config.sub and config.guess (Closes: #142308)

 -- Erich Schubert <erich@debian.org>  Thu, 11 Apr 2002 23:10:55 +0200

libopenobex (0.9.8-3) unstable; urgency=low

  * Improved Description, which was not quite correct. (Closes: #140732)

 -- Erich Schubert <erich@debian.org>  Fri,  5 Apr 2002 17:47:45 +0200

libopenobex (0.9.8-2) unstable; urgency=low

  * Added missing build-Dependency on libglib1.2

 -- Erich Schubert <erich@debian.org>  Sat, 30 Mar 2002 11:22:02 +0100

libopenobex (0.9.8-1) unstable; urgency=low

  * Initial Release (Closes: #136310).

 -- Erich Schubert <erich@debian.org>  Fri,  1 Mar 2002 11:45:23 +0100

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2017 FileWatcher.com