Filewatcher File Search File Search
Catalog
Content Search
» » » » » openoffice.org-l10n-pt-br_2.4.1+dfsg-1+lenny12_all.deb » Content »
pkg://openoffice.org-l10n-pt-br_2.4.1+dfsg-1+lenny12_all.deb:2001148/usr/share/doc/openoffice.org-l10n-pt-br/  info  control  downloads

openoffice.org-l10n-pt-br - Portuguese_brazilian language package for OpenOffice.org…  more info»

changelog.Debian.gz

openoffice.org (1:2.4.1+dfsg-1+lenny12) oldstable-security; urgency=high

  * ooo-build/patches/src680/CVE-2011-2713.OpenOffice3.2.1.diff: fix
    CVE-2011-2713 (Out-of-bounds read in DOC sprm)

 -- Rene Engelhard <rene@debian.org>  Sun, 25 Sep 2011 09:35:22 +0000

openoffice.org (1:2.4.1+dfsg-1+lenny11) stable-security; urgency=low

  * ooo-build/patches/src680/security-fixes-from-cws-impress208.diff: fix
    possible heap overflow when reading manipulated TGA images
    (CVE-2010-4643) 

 -- Rene Engelhard <rene@debian.org>  Wed, 05 Jan 2011 22:02:59 +0100

openoffice.org (1:2.4.1+dfsg-1+lenny10) stable-security; urgency=high

  * ooo-build/patches/src680/security-fixes-from-cws-os145.diff: fix
    CVE-2010-4253: Heap based buffer overflow, PPT files.

 -- Rene Engelhard <rene@debian.org>  Mon, 29 Nov 2010 17:55:27 +0000

openoffice.org (1:2.4.1+dfsg-1+lenny9) stable-security; urgency=high

  * ooo-build/patches/src680/tread-invalid-path-segments-correctly.diff:
    fix directory traversal vulnerability in OOo (CVE-2010-3450)
  * ooo-build/patches/src680/cws-hb22.diff: fix security issues:
    - soffice script does not treat empty LD_LIBRARY_PATH like unset one
      (CVE-2010-3689)
    - Crash in WW8DopTypography::ReadFromMem (CVE-2010-3454)
    - Crash in SwRTFParser::ReadNumSecLevel (CVE-2010-3452)
    - Out of bounds write in WW8ListManager::WW8ListManager()
      (CVE-2010-3453)
    - Loading certain RTF document leads to corrupt table model
      (CVE-2010-3451)

 -- Rene Engelhard <rene@debian.org>  Fri, 01 Oct 2010 16:24:28 +0200

openoffice.org (1:2.4.1+dfsg-1+lenny8) stable-security; urgency=high

  * ooo-build/patches/src680/workspace.impress197.diff: fix CVE-2010-2935 and
    CVE-2010-2936 aka SA40775:
    two buffer-overflow vulnerabilities in OpenOffice.org Impress

 -- Rene Engelhard <rene@debian.org>  Thu, 19 Aug 2010 11:59:29 +0000

openoffice.org (1:2.4.1+dfsg-1+lenny7) stable-security; urgency=high

  * pyuno.avoid.execution.for.browsing.funcs.legacy.python.diff:
    avoid execution of python code when browsing macros (CVE-2010-0395)

 -- Rene Engelhard <rene@debian.org>  Mon, 08 Mar 2010 22:33:26 +0100

openoffice.org (1:2.4.1+dfsg-1+lenny6) stable-security; urgency=high

  * ooo-build/patches/src680/vba-macro-properties-2.4.diff: fix vba macros
    not honouring macro security settings (CVE-2010-0136) 

 -- Rene Engelhard <rene@debian.org>  Sat, 26 Dec 2009 21:24:42 +0100

openoffice.org (1:2.4.1+dfsg-1+lenny5) stable-security; urgency=high

  * ooo-build/patches/src680/libxmlsec-CVE-2009-0217.diff: fix
    CVE-2009-0217 in the internal libxmlsec copy (just the nss part)
  * ooo-build/patches/src680/libxmlsec-findcerts.diff: adapt

 -- Rene Engelhard <rene@debian.org>  Tue, 15 Dec 2009 22:03:15 +0000

openoffice.org (1:2.4.1+dfsg-1+lenny4) stable-security; urgency=high

  * ooo-build/patches/src680/cws-sjooh680sf01.diff: fix
    "OpenOffice.org XPM Import Integer Overflow" (CVE-2009-2949) and
    "OpenOffice.org GIF Import Heap Overflow" (CVE-2009-2950)
  * ooo-build/patches/src680/cws-hb32showstoppers3ooh680.diff: fix
    "OOO sprmTDefTable issue" (CVE-2009-3301) and
    "OOO sprmTSetBrc issue" (CVE-2009-3302)

 -- Rene Engelhard <rene@debian.org>  Fri, 13 Nov 2009 22:19:53 +0100

openoffice.org (1:2.4.1+dfsg-1+lenny3) stable-security; urgency=high

  * rebuild to get correct $LANGPACKISOS in e.g. broffice.org... 

 -- Rene Engelhard <rene@debian.org>  Sun, 21 Jun 2009 01:12:03 +0200

openoffice.org (1:2.4.1+dfsg-1+lenny2) stable-security; urgency=high

  * patches/src680/wmf-pattern-brush.diff: backport fix from
    ooo-build-3-0-1 branch fixing similar issues like CVE-2008-2237
    in that patch

 -- Rene Engelhard <rene@debian.org>  Tue, 16 Jun 2009 00:00:10 +0200

openoffice.org (1:2.4.1+dfsg-1+lenny1) stable-security; urgency=high

  * patches/src680/sw.safe_tdelete_tinsert.diff: fix CVE-2009-0200
    (OpenOffice.org Word Document sprmTDelete Integer Underflow) and
    CVE-2009-0201 (OpenOffice.org Word Document sprmTInsert Buffer Overflow)

 -- Rene Engelhard <rene@debian.org>  Fri, 22 May 2009 10:30:16 +0200

openoffice.org (1:2.4.1+dfsg-1) stable; urgency=low

  * repackage .orig.tar.gz without rfc1345.txt in liblayout.zip
    (closes: #516784)
  * debian/rules:
    - add build-conflicts against xulrunner-dev if MOZILLA != libxul
    - remove rfc1345.txt in liblayout.zip in get-orig-source
  * debian/control.in:
    - build-conflict against g++-4.3 (>> 4.3.2-1.1) (reason: #514830)
    - remove http://udk.openoffice.org/python/python-bridge.html from
      python-unos description, we already have it in Homepage:
  * debian/presubj:
    - directly point to http://wiki.debian.org/OpenOffice#debug in IV
     (closes: #517987)
  * debian/README.Debian:
    - remove openoffice.debian.net (closes: #517978)

 -- Rene Engelhard <rene@debian.org>  Wed, 11 Mar 2009 21:04:22 +0100

openoffice.org (1:2.4.1-17) unstable; urgency=medium

  * ooo-build:
    - update
      - i88376.diff: backport fix for i88376 from 2.4.2 (closes: #481518)

 -- Rene Engelhard <rene@debian.org>  Tue, 20 Jan 2009 09:44:48 +0100

openoffice.org (1:2.4.1-16) unstable; urgency=medium

  * ooo-build:
    - update (r15087)
      - hidden-text-backport.diff: apply patch to fix handling of display:text
        (closes: #507865)
  * debian/control.in:
    - openoffice.org-base-core needs to depend on openoffice.org-core....
  * debian/rules:
    - fix extra license/readme file removal
    - update xulrunner build-dep in MOZILLA=libxul case for current reality
      (we need it here, too, if we do #511477 for lenny..)
  * debian/control.reportdesign.in:
    - add missing Depends: on ${java-runtime-depends}
  * debian/presubj: point to OpenOffice.orgs README sections
    ("Problems During Program Startup" and "File Locking"). 
  * debian/rules, control.gcj.in: disable ppc for -gcj as gij doesn't work
    there anyway (#478760). Fix Architecture: of -gcj to not include
    non-Java archs.
  * debian/source.lintian-overrides: override bogus (lintian bug #511859)
    missing-build-dependency-for-dh_-command
  * debian/shell-lib.sh: remove long obsolete "trap {...}". bashism anyway.
    Thanks lintian.

 -- Rene Engelhard <rene@debian.org>  Thu, 15 Jan 2009 23:26:00 +0100

openoffice.org (1:2.4.1-15) unstable; urgency=medium

  * ooo-build:
    - update (r14848)
      - update sdbc postgresql driver to 0.7.6

 -- Rene Engelhard <rene@debian.org>  Sun, 14 Dec 2008 23:49:35 +0100

openoffice.org (1:2.4.1-14) unstable; urgency=high

  * ooo-build:
      - sensible-browser.diff: really fix typo (closes: #505429)
  * debian/rules:
    - add hackaround to use ENABLE_QA_TOOLS=n on ia64 as "jar" segfaults
      there (and only there) (closes: #507135)

 -- Rene Engelhard <rene@debian.org>  Wed, 03 Dec 2008 09:30:50 +0100

openoffice.org (1:2.4.1-13) unstable; urgency=medium

  * ooo-build:
    - update (r14583)
      - pythonloader-no-DEBUG.diff: don't set DEBUG=1 in pythonloader.py
        (closes: #491922)
  * debian/control.postgresql.in:
    - only suggest postgresql
  * debian/rules:
    - don't add | java2-runtime to JAVA_RUNTIME_DEPENDS as we don't work
      with cacao-oj6 
    - install the extension.desktop with Type=MimeType (to
      /usr/share/mimelnk/application/vnd.openofficeorg.extension.desktop) and
      install icons for it from ooo-build. Also actually install
      openoffice.org.xml for shared-mime-info (closes: #502737)
  * debian/control.in:
    - conflict against cacao-oj6-jre (closes: #495694)
  * debian/broffice.org.{preinst,postrm}.in: add
    /usr/share/mimelnk/application/vnd.openofficeorg.extension.desktop

 -- Rene Engelhard <rene@debian.org>  Wed, 26 Nov 2008 00:23:55 +0100

openoffice.org (1:2.4.1-12) unstable; urgency=high

  * ooo-build
    - update
      - reportdesign-mention-package.diff: Czech translation
      - no-latex-filter-without-writer2latex.diff: don't include LaTeX stuff
        in Writers filter list with --without-writer2latex (closes: #502549)
      - sensible-browser.diff: run kde-open on mailto: URLs in kde-open-url.sh
        instead of removed sensible-ooomua (closes: #502852)
      - cws-sjfixes07.diff: fix CVE-2008-2237 (WMF META_ESCAPE Integer      
        Overflow Vulnerability) and CVE-2008-2238 (multiple EMF parser flaws)
  * debian/rules:   
    - make ootestapi find OOoRunnerLight.jar by setting the necessary symlink
  * debian/control.qa.in:
    - make -qa-api-tests depend on Java as it needs OOoRunnerLight.jar to be
      run to be used. Make -qa-tools suggest it.
  * debian/copyright, debian/README.Debian-source: fix 

 -- Rene Engelhard <rene@debian.org>  Sun, 26 Oct 2008 14:52:57 +0100

openoffice.org (1:2.4.1-11) unstable; urgency=high

  * The "SIGH!" release.
  * ooo-build:
   - update (r14262)
     - unxsplash-rework.diff: fix syntax error, thanks Stefan Lippers-Hollmann
     - soffice-remove-webwizard.diff: fix bashism/syntax error, thanks
       Stefan Lippers-Hollmann again
     (closes: #501664)

 -- Rene Engelhard <rene@debian.org>  Thu, 09 Oct 2008 13:31:52 +0200

openoffice.org (1:2.4.1-10) unstable; urgency=medium

  * ooo-build:
    - update (r14235)
      - more ko translation fixes
      - sc-skip-overlapped-cells.diff: check the vadility of row numbers
        (closes: #499374)
      - math-draw-generic-name.diff: add GenericName for
        Draw (closes: #498922) and Math (closes: #498924) 
      - cws-chart28.diff: backport from 2.4.2/3.0: fix crash when displaying
        charts with clipped data
      - soffice-remove-webwizard.diff: remove WebWizard remains from user
        profile on starup if existing (closes: #360575) as that apparently
        also is an issue in 2.x->2.x upgrades. Thanks Marc Haber for reminding
  	me...
      - soffice-detect-mozilla-certificates.diff: only do a full find for
        cert8.db when we don't find it with just maxdepth 2 (closes: #499062) 
      - unxsplash-rework.diff: don't run the external oosplash with -nologo
        (no splash anyway) and with the (new) -no-oosplash
      - i89812.diff: backport from 2.4.2/3.0: fix for Writer crash after
        pasting webpage from clipboard
  * debian/rules:
    - also complain in binary-indep when Mono is disabled
    - mkdir .../share/samples/<lang> in all langpacks (closes: #496047)
  * debian/openoffice.org-report-builder-bin.overrides.lintian: fix
  * debian/*.mime: run with -no-oosplash (closes: #396276)
  * debian/control.in:
    - make the openoffice.org metapackage depend on
      openoffice.org-report-builder-bin as the libs contained there are
      in the standard OOo install and the SRB needs it (even more when
      installed not from the deb)

 -- Rene Engelhard <rene@debian.org>  Tue, 07 Oct 2008 15:45:16 +0200

openoffice.org (1:2.4.1-9) unstable; urgency=medium

  * debian/control.reportdesign.in:
    - -report-builder-bin contains librpt* which is linked against libraries
      from -base so that one should depend on -base, not -report-builder
  * debian/rules:
    - fix senddoc fixing (add chmod 755) to keep senddoc executable 
      closes: #497618)

 -- Rene Engelhard <rene@debian.org>  Thu, 04 Sep 2008 19:03:26 +0200

openoffice.org (1:2.4.1-8) unstable; urgency=high

  * debian/control.in:
    - Homepage: http://www.go-oo.org, thanks Renato Yamane 
  * debian/rules:
    - remove leftover debugging echos to /tmp/log.obr.$$ in senddoc
      (closes: #496361) - CVE-2008-4937

 -- Rene Engelhard <rene@debian.org>  Tue, 26 Aug 2008 01:32:02 +0200

openoffice.org (1:2.4.1-7) unstable; urgency=medium

  * ooo-build:
    - update to debian-2-4-1 branch
  * debian/control.mono.in:
    - Section: libs to fix override disparity
  * merge from experimental/3.0:
    - debian/control.in:
      + remove xutils build-dep, nas was using xmkmf and it's long gone here
  * debian/control.in:
    - Standards-Version: 3.8.0 (already following it)
    - For upgrades from bpo packages add a Replaces on
      openoffice.org-java-common to -base because of hsqldb, see below.
      (closes: #494512)
  * debian/copyright:
    - wrap "Debian package authors:" line to please lintian
  * debian/rules:
    - remove obsolete [$(OOO_ARCHS)] qualifier from python-dev builddep
      (closes: #491623)
    - put hsqldb.jar also to -base  with internal hsqldb so that we don't
      get file differences between sids package and backports.
  * debian/rules, debian/control.reportdesign.in:
    - split librpt* out into a -report-builder-bin package. Newer versions of
      the SRB also often work with older librpt*/OOo, but that would not work
      with the current packaging due to shlibdeps.

 -- Rene Engelhard <rene@debian.org>  Wed, 20 Aug 2008 16:14:21 +0200

openoffice.org (1:2.4.1-6) unstable; urgency=low

  * ooo-build
    - update (r13167)
  * debian/rules:
    - only try to copy debian/tmp/pkg/openoffice.org-{help,l10n}-xx when
      it's there
  * debian/control.mono.in, debian/rules:
    - hrm, we probably shouldn't make binary-arch depend on binary-indep.
      Hardcode cli-uno-bridges dependencies instead of relying on
      dh_clideps

 -- Rene Engelhard <rene@debian.org>  Fri, 11 Jul 2008 22:25:33 +0200

openoffice.org (1:2.4.1-5) unstable; urgency=medium

  * ooo-build:
    - update (13085)
  * debian/rules:
    - reenable Java for armel, gcj-4.3 OOM reportedly fixed. Add build-dep
      on gcj-4,3 (>= 4.3.1-2) for armel
  * debian/rules, debian/control.mono.in, debian/*.installcligac: split
    cli_*dll in various subpackages to make the packages CLI policy compliant.
    Rename libuno-cil to cli-uno-bridge. Move the files in libuno*-cil to
    /usr/lib/cli/uno-1.x
  * debian/rules, debian/control.in:
    - split emailmerge out into an own package. Don't make -writer depend on
      python-uno anymore so that -writer (and openoffice.org) still can be
      installed when python-uno is not installable (like at python-defaults
      changes)
  * debian/openoffice.org-emailmerge*: unopkg add --shared mailmerge.py
    to register mailmerge.py as it otherwise doesn't seem to work
    (closes: #488875)

 -- Rene Engelhard <rene@debian.org>  Mon, 07 Jul 2008 21:32:28 +0200

openoffice.org (1:2.4.1-4) unstable; urgency=medium

  * ooo-build
    + update (r12994)
      + sw-field-patch-fix-competing-protection.diff: for the competing
        protection problem from n#400884 (really closes: #477653)
      + distro-configs/Common.conf.in: randr reenabled per default
  * debian/rules:
    - reenable randr
    - reenable mono, mono seems to be fixed on amd64
  * debian/control.in:
    - make openoffice.org metapackage depend on ttf-liberation. Remove
      msttcorefonts suggestion.
  * debian/openoffice.org-core.postrm.in:
    - fix. rm -rf /var/spool/openoffice, not /var/spool/openoffice2

 -- Rene Engelhard <rene@debian.org>  Tue, 01 Jul 2008 23:06:23 +0200

openoffice.org (1:2.4.1-3) unstable; urgency=medium

  * ooo-build:
    - update (r12885)
      + cws-cmcfixes47-sw.diff: backport fix from 3.0 to not open Word
        documents read-only (closes: #477653)
      + cws-cmcfixes47-extensions.diff: fix mozilla plugin for 64-bit mozilla
        API
      + distro-configs/Common.conf.in: --disable-randr (closes: #485833)
  * debian/rules:
    + reenable mozilla plugin for 64bit archs
    + add ENABLE_RANDR conditional, remove libxrandr2 Recommends:

 -- Rene Engelhard <rene@debian.org>  Fri, 13 Jun 2008 23:41:39 +0200

openoffice.org (1:2.4.1-2) unstable; urgency=low

  * ooo-build:
    - update (r12856)
      + ooo86080.unopkg.bodge.diff: fix bashism: s/==/=/ (closes: #485706)

 -- Rene Engelhard <rene@debian.org>  Wed, 11 Jun 2008 09:04:10 +0200

openoffice.org (1:2.4.1-1) unstable; urgency=low

  * OpenOffice.org 2.4.1 final
  * upload to unstable
  * ooo-build:
    - update (r12837)
  * debian/control.in:
    - only recommend -fitler-binfilter. (closes: #484287)
    - conflict against libgtk2.0-0 = 2.12.10-1 on amd64 because of
      #484580 and #484758.
  * debian/rules:
    - install also other resolutions than 48x48 for the ooo-build/desktop 
      icons, thanks Chris Cheney
  * debian/rules, debian/broffice.org.*.in:
    - fixup openoffice.applications (closes: #485437) and stop specifying
      unopkg with full paths (we don't do it for ooffice either and
      /usr/bin/unopkg does it)
  * debian/copyright:
    - update

 -- Rene Engelhard <rene@debian.org>  Mon, 09 Jun 2008 20:15:06 +0200

openoffice.org (1:2.4.1~rc2-1) experimental; urgency=low

  * OpenOffice.org 2.4.1 rc2 (OOH680_m17)
  * ooo-build:
    - update (r12720)
  * debian/control.in:
    - s/meta package/metapackage/
  * debian/rules:
    - fix typo in installing bug scripts/presubj for arch-indep packages

 -- Rene Engelhard <rene@debian.org>  Fri, 30 May 2008 13:42:13 +0200

openoffice.org (1:2.4.1~rc1-1) experimental; urgency=low

  * OpenOffice.org 2.4.1 rc1 (OOH680_m16)
    - now doesn't need a patched icu (public SetBreakType) anymore for
      building
  * ooo-build:
    - use ooo-build-2-4-1 branch
    - update (r12682)
      + allows to change broken java configuration
        This closes: #451928, #452925
        Most probably also closes: #454996
  * debian/rules:
    - we also need to build-depend on libnss3-dev (closes: #481996)
    - reenable system-icu for etch backports
    - add get-orig-source target
    - remove overseen $(OOO_ARCHS); make control/maintscripts depend on all
      .ins for it (removes duplicate contro.gcj.in). Thanks Chris Cheney
    - disable mono on amd64 and OGLtrans on 64-bit archs
    - improve USE_STLPORT/ENABLE_MONO/ENABLE_OGLTRANS/MOZILLA conditionals to 
      add the right build-deps even when the arch we generate it doesn't build
      e.g. with STLport
  * debian/control.in:
   - remove libicu build-conflicts
  * debian/control.in, debian/rules:
    - libsapdbc-java was removed, stop suggesting it and adding it to OOos
      CLASSPATH

 -- Rene Engelhard <rene@debian.org>  Tue, 27 May 2008 22:44:43 +0200

openoffice.org (1:2.4.1~ooh680m14-1) experimental; urgency=low

  * OpenOffice.org 2.4.1 snapshot OHO680_m14
  * ooo-build:
   - update (r12554)
  * debian/rules:
    - update for new xulrunner 1.9 packaging using iceape-dev.
      Use MOZILLA=iceape (closes: #480813)
    - specify -Nopenoffice.org-gcj when building without Java
    - remove extra dependency changing for libhyphen0, we now get a
      dependeny on 2.4 "for free"; build-dep on libhyphen-dev (>= 2.4)
  * debian/control.qa.in:
    - fix -qa-tools' depends
  * debian/copyright: fix "Obtained from", mention go-oo.org. Remove obsolete
    section about odk/sdk_oo
  * debian/control.in, debian/rules:
    - fix Vcs-Svn:, make it a generated field

 -- Rene Engelhard <rene@debian.org>  Mon, 12 May 2008 11:38:39 +0200

openoffice.org (1:2.4.0-6) unstable; urgency=low

  * ooo-build:
    - update (r12409)
  * debian/rules:
    - fix debian/rules to add archs to OOO_SCSOLVER_ARCHS when they build OOo
      to not get useless build-deps there
    - support xulrunner 1.9
    - fix java-gcj-compat-dev build-depends conditional logic to set the
      right versioned build-dep for !etch
    - correct control.mono.in inclusion regardless of host architecture
    - explicitely set ENABLE_REPORTDESIGN=n in arch conditonals for
      disabling java (-> arm(el)). Only depend on openoffice.org-writer2latex
      when Java is enabled
    - also install pythonscript.py into $(SITE_PACKAGES)
  * debian/control.in:
    - make the openoffice.org metapackage depend on ttf-dejavu, since upstream
      OOo ships it
  * debian/scripts/vars.ppc64: actually add 
  * debian/control.in, debian/rules:
    - remove the "build libmythes-dev only" option as OOo is now enabled
      on all important archs. Remove the now unndeeded arch specifiers
      on builddeps. Hopefully makes mips(el) parse the builddep line
      again without segfault...
  * debian/control.in:
    - make impress recommend libxrandr2 as OOo now can detect size
      changes through it
    - build-depend against libxrandr-dev

 -- Rene Engelhard <rene@debian.org>  Thu, 01 May 2008 16:25:12 +0200

openoffice.org (1:2.4.0-5) unstable; urgency=low

  * rebuild with python-central 0.6.4 (closes: #476678)
  * ooo-build
    - use ooo-build-2-4 branch
    - update (r12270)
      + patches/src680/configures-explicit-arch.diff: fix up for
        the internal icu build
      + patches/src680/sc-openformula-frequency.diff: fixed a silly regression
        that prevents the built-in FREQUENCY function from working properly
        (closes: #477104)
      + patches/src680/sdk-settings-honour-linux.diff: honour also linux
        as in s390-ibm-linux instead of only linux-gnu (closes: #477153)
  * debian/rules:
    - revert libstlport4.6-dev builddep bump. Will break our builddeps
      for etch-backports and testing now has already -ldbl
    - set PACKAGE_NPSOPLUGIN=n when MOZILLA= (--disable-mozilla)
    - enable scsolver for armel (lp-solve now available)
  * debian/control.in, debian/rules:
    - only add a dependency on openoffice.org-officebean to openoffice.org
      when openoffice.org-officebean is actually built (i.e. we build with
      Java), thaks Chris Cheney
  * debian/changelog: mention the various security fixes in OOH680_m5 and
    OOH680_m6
  * merge from Ubuntu:
    - debian/rules:
      + Correct control.mozilla.in inclusion regardless of host architecture

 -- Rene Engelhard <rene@debian.org>  Mon, 21 Apr 2008 17:02:51 +0200

openoffice.org (1:2.4.0-4) unstable; urgency=medium

  * rebuild against python 2.5 (closes: #476220)
  * ooo-build:
    - update (r12156)
      + disables cjk-character-units-*.diff as they cause some problems
        (closes: #474028)
      + emf+-canvas-vcl-non-closed-polygon.diff: fixed invalid access
        (closes: #465423)
      + sw-hindi-numbers.diff: revert change for i#81577 to fix number
        displaying in hebrew docs
      + fixes uninitialized memory in manual spellchecking (closes: #469894)
    - src: update GSIs from ftp.linux.cz: bg da et fi ga mk nb nn
  * debian/rules:
    - handle new aotcompile.py location in java-gcj-compat-dev due to
      python-central >= 0.6 (closes: #475987)
    - bump libstlport4.6-dev builddep to ensure building against
      libstlport4.6ldbl
    - reenable system-hunspell
    - bump libhyphen0 dep to 2.3-1-3
    - set MOZILLA= when arch not in OOO_MOZILLA_ARCHS
    - fix OOO_OGLTRANS_ARCHS conditional
    - disable Java (OOM) and mozilla (no xulrunner/nss/nspr available yet)
      on armel
  * debian/rules, ooo-build/patches/src680/configures-explicit-arch.diff:
    explicitely specify --host and --build (closes: #475037)
  * debian/control.in, debian/control.reportdesign.in: Fix long
    description, thanks Gerfried Fuchs (closes: #475992)
  * merge from Ubuntu:
    - debian/*.mime:
      + Update and sort mime-types.
    - debian/rules:
      + Use openjdk-6-jre instead of icedtea-java7-jre.
    - debian/control.reportdesign.in:
      + change %OOO_ARCHS% to %OOO_JAVA_ARCHS%

 -- Rene Engelhard <rene@debian.org>  Mon, 14 Apr 2008 12:23:51 +0200

openoffice.org (1:2.4.0-3) unstable; urgency=low

  * The "Third time is a charm?" release.

  * ooo-build:
    - update (r12025 - ooo-build 2.4.0.5)
      + now installs a /usr/bin/unopkg wrapper (closes: #319548)
    - src: update GSIs from ftp.linux.cz: et ga
  * debian/shell-lib.sh, debian/openoffice.org{,-common}.preinst.in:
    - don't query docbook-xmls conffiles but ours....
  * debian/rules:
    - actually add text/rtf to ooo-writer.desktop (closes: #472952)
  * debian/openoffice.org-common.manpages: install unopkg.1

 -- Rene Engelhard <rene@debian.org>  Fri, 28 Mar 2008 10:53:56 +0100

openoffice.org (1:2.4.0-2) unstable; urgency=low

  * Brown paper bag release.
  * build with a correct control to get the needed libstlport4.6-dev builddep
    on i386
  * debian/rules:
    - remove arm also from OOO_MOZILLA_ARCHS and OOO_NPSOLPLUGIN_ARCHS. Fix
      "build-only-mythes" conditional to actually be on effect for arm

 -- Rene Engelhard <rene@debian.org>  Fri, 28 Mar 2008 00:28:17 +0100

openoffice.org (1:2.4.0-1) unstable; urgency=low

  * OpenOffice.org 2.4.0 final
  * ooo-build:
    - update (r11988)
      + buildfix-oox-depends-on-unotools.diff: make oox
        depend on unotools (closes: #471633)
      + sc-fix-value-iterator.diff; fixes e.g MIN function
        (closes: #471416)
  * debian/control.in:
    - remove obsolete libsndfile1-dev builddep
    - also build-conflict against nvidia-glx-legacy-dev
    - fix Vcs-Bzr:
  * debian/*.lintian-overrides*: remove "unused-override"s
  * debian/openoffice.org-{core,ogltrans}.control.bug:
    Report-With: infos about fglrx and nvidia drivers
  * debian/rules:
    - disable binfilter builds for arm(el)
    - disable arm builds completely as it's "an obsolete arch". Still keep
      armel (won't block testing migration)
    - don't build-depend on g{cc,++}-4.3 on s390 anymore as it's the default
      now anyway. Build-depend on gcc (>> 4.3.0) and g++ (>> 4.3.0)
      instead
    - fix l10n-sr up to not conflict against -sr-cs as that's our
      etch->lenny transitional package.

 -- Rene Engelhard <rene@debian.org>  Wed, 26 Mar 2008 22:42:18 +0100

openoffice.org (1:2.4.0~rc6-1) unstable; urgency=low

  * OpenOffice.org 2.4.0 rc6 (aka OOH680_m12)
  * ooo-build:
    - update (r11918)

 -- Rene Engelhard <rene@debian.org>  Sun, 16 Mar 2008 21:07:25 +0100

openoffice.org (1:2.4.0~rc5-1) unstable; urgency=low

  * OpenOffice.org 2.4.0 rc5 (aka OOH680_m11)
  * ooo-build:
    - update (r11890)

 -- Rene Engelhard <rene@debian.org>  Thu, 13 Mar 2008 12:22:53 +0100

openoffice.org (1:2.4.0~rc4-1) unstable; urgency=low

  * OpenOffice.org 2.4.0 rc4 (aka OOH680_m10)
  * ooo-build:
    - update (r11862)
      - ubuntu-soffice-config.diff: set $HOME from getent if not set
        (closes: #431976)
      - src:
        - update GSIs from ftp.linux.cz:  bg da et fi ga mk ro uz
  * debian/rules:
    - suggest libnss-1d-dbg instead of libnss3-0d-dbg (closes: #469872)
  * debian/control.in:
    - GTk -> GTK+, thanks lintian
  * debian/udk*ref.in
    - Apps/Programming -> Programming, thanks lintian

 -- Rene Engelhard <rene@debian.org>  Mon, 10 Mar 2008 21:08:38 +0100

openoffice.org (1:2.4.0~rc3-1) unstable; urgency=low

  * OpenOffice.org 2.4.0 rc3 (aka OOH680_m9)
  * ooo-build
    - update (r11840)
  * debian/rules:
    - enable s390 build (don't enable mono); force gcc 4.3 to workaround
      ICE(s)
  * debian/control.in:
    - build-depend on libxtst-dev

 -- Rene Engelhard <rene@debian.org>  Fri, 07 Mar 2008 08:22:20 +0100

openoffice.org (1:2.4.0~rc2-1) unstable; urgency=low

  * OpenOffice.org 2.4.0 rc2 (aka OOH680_m8)
    - fixes printing of control elements (closes: #467168)
  * ooo-build:
    - update (r11750)
  * debian/rules, debian/control.ure.in:
    - introduce ure:Version variable (closes: #466932)
  * debian/rules:
    - fix self-reference of GCJ_JAWT_DEPENDS on etch-backports
      (closes: #466932)
  * debian/control.in:
    - remove obsolete libstartup-notification0-dev builddep

 -- Rene Engelhard <rene@debian.org>  Thu, 28 Feb 2008 23:00:39 +0100

openoffice.org (1:2.4.0~rc1-3) unstable; urgency=low

  * ooo-build:
    - update (r11700)
      + cws-ia64port01.diff: backport ia64 port
      + ubuntu-soffice-config.diff: remove disabling of thai autohinting,
        thanks Theppitak Karoonboonyana (closes: #467180)
  * debian/rules:
    - use readlink -f for determining libstlport_gcc.so.4.6s location
      (closes: #466040)
    - BUILD_IA64=y
    - --disable-mono for arm(el)
    - add GCJ_JAWT_DIR to LD_LIBRARY_PATH for a try to fix FTBFS on mips
    - install pythonloader.py into $(PYTHON_SITE) (closes: #466412)
    - temporarily build with internal hunspell (closes: #459943)
    - build with libdb4.6 (closes: #464754)
    - add symlink /usr/share/doc/openoffice.org-dev/index.html ->
      /usr/lib/openoffice/sdk/index.html. Is the other way around like
      the submitter suggested but still closes: #420804 AFAIS.
      Replace non-working link to license.html with link to
      http://www.gnu.org/licenses/lgpl.html
    - openoffice$(VER) -> $(OODIRNAME)
    - build against libsuitesparse-3.1.0; adapt build-depends to require
      the new version (and the lp-solve built against libsuitesparse-3.1.0)
    - add ttf-thai-tlwg FONT_SUGGESTS
  * debian/control.in:
    - only recommend openoffice.org-writer2latex at -writer. Add it
      to the "openoffice.org" metapackage as Depends (closes: #466170)
    - only suggest -style-{hicontrast,industrial} (closes: #466494)

 -- Rene Engelhard <rene@debian.org>  Mon, 25 Feb 2008 18:46:30 +0100

openoffice.org (1:2.4.0~rc1-2) unstable; urgency=low

  * upload to unstable
  * ooo-build:
    - update (r11592)
  * debian/rules:
    - build-depend on debhelper >= 5.0.51~ for dh_icons, thanks lintian
    - make arm build really use --without-java for the build
  * debian/libuno-cil.installcligac.in:
    - also register cli_uno_bridge.dll (although versioned 0.0.0.0) into the
      GAC
  * debian/openoffice.org-core.control.bug:
    - s/openoffice.org-filter-so52/openoffice.org-filter-binfilter/
  * debian/openoffice.org-{report-builder,ogltrans}.control.bug:
    - add report-with: openoffice.org-base / openoffice.org-impress
  * debian/*.script.bug:
    - new bug scripts listing all extensions (-core) or the extension infos
      (-report-builder, -sdbc-postgresql, -presentation-minimizer)

 -- Rene Engelhard <rene@debian.org>  Fri, 15 Feb 2008 14:15:08 +0100

openoffice.org (1:2.4.0~rc1-1) experimental; urgency=low

  * OpenOffice.org 2.4.0 rc1 (aka OOH680_m7)
  * ooo-build:
    - update (r11558)
    - src: update GSIs from frp.linux.cz (mk, ro, uz, vi)
  * debian/control.in:
    - fix logic error, we of course should conflict against old
      openoffice.org-calcs in the new common, not the other way around
      (really closes: #464544).
      Go safe for the future; make -common Conflicts: against all the modules
      (<< ${base-version})
    - build-conflict against flex (= 2.5.34-1) on amd64
    - s/python/Python/, thanks lintian. Add Homepage: field for python-uno
  * debian/control.qa.in:
    - add ${shlibs:Depends}, thanks lintian
  * debian/control.ure.in:
    - make ure-dbg depend on ure, thanks lintian
  * debian/control.postgresql.in:
    - s/postgresql/PostgreSQL/, thanks linttian

 -- Rene Engelhard <rene@debian.org>  Wed, 13 Feb 2008 09:28:35 +0100

openoffice.org (1:2.4.0~ooh680m6-3) experimental; urgency=low

  * ooo-build:
    - update (r11531)
  * debian/control.in:
    - make -calc conflict against openoffice.org-common (<< 1:2.3.0)
      (closes: #464544)

 -- Rene Engelhard <rene@debian.org>  Fri, 08 Feb 2008 00:19:05 +0100

openoffice.org (1:2.4.0~ooh680m6-2) experimental; urgency=low

  * ooo-build:
    - update (r11513)
  * debian/rules:
    - add some missing/fix arch qualifiers to libsuitesparse-dev/libgcj-bc
      builddeps
    - fix typos in specifying the libxml.jar and libfonts.jar
    - reinstate Common-math.xcu moving (somewhen got lost(?)) to prevent
      file conflicts on upgrade
  * debian/control.ogltrans.in:
    - bump depends to force fixed openoffice.org-common containing the correct
      Impress.xcs

 -- Rene Engelhard <rene@debian.org>  Wed, 06 Feb 2008 02:09:14 +0100

openoffice.org (1:2.4.0~ooh680m6-1) experimental; urgency=low

  * new upstream snapshot (OOH680_m6)
    - fixes CVE-2007-4770 and CVE-2007-4771 for the (unused) internal icu
      copy
  * ooo-build:
    - update (r11494)
  * debian/rules:
    - stop adding libgcj9-0-awt to java-runtime-depends. Make
      java-gcj-compat depends of officebean versioned to force 1.0.77-4 which
      already depends on the -awt package now
    - specify --with-XXXX-jar for the report-builder jars explcitely

 -- Rene Engelhard <rene@debian.org>  Sun, 03 Feb 2008 23:02:29 +0100

openoffice.org (1:2.4.0~ooh680m5-1) experimental; urgency=high

  * new upstream snapshot (OOH680_m5)
    - adds https support for WebDAV (closes: #244280)
    - officially adds possibility to input formulas starting with -/+
      (closes: #433360)
    - now queries CUPS for printers again when opening the print dialogue;
      not only on startup (closes: #290016)
    - doesn't link libofficebean.so with -lgcj anymore (closes: #441202)
    - fixes CVE-2007-5745, CVE-2007-5746, CVE-2007-5747 and
      CVE-2008-0320
  * ooo-build:
    - use trunk again (r11432)
    - src:
      + use (new) OOH680 GSIs from ftp.linux.cz
        . new: ro, gd
      + add eu GSI from Issue 85486
  * debian/rules, debian/scripts/vars.mips{,el}, debian/scripts/vars.arm{,el}:
    (re)add conditionals and vars for new mips(el)/armel and revived arm
    support; enable
  * debian/rules, debian/scripts/vars.ia64: first preparations for the
    (upcoming) ia64 port
  * debian/rules:
    - fix configure flags for "no mozilla" case, we need to specify
      --without-system-mozilla explicitely
  * debian/control.in, debian/rules,
    debian/openoffice.org-presentation-minimizer*:
    - package the new "Presentation Minimizer" extension as
      openoffice.org-presentation-minimizer
  * debian/control.ure.in, debian/rules, debian/ure.overrides.lintian.in:
    - package the URE
  * debian/rules:
    - build against OpenSSL versions of curl and (especially) neon again
      as the webdav ucp now directly links against openssl...
      (reopens: #391671). Use system-openssl.
    - ENABLE_OPENGL=y
    - bump dmake builddep
    - fix BUILD_BINFILTERS conditional to work
    - add PACKAGE_WRITER2LATEX / USE_EXTERNAL_WRITER2LATEX conditionals
    - s/stlport4/stlport/
    - fix ENABLE_JAVA=n build, build the help as it doesn't need Java anymore,
      don't build report-builder
    - enable the report-builder using the internally-built jars for the etch
      backport now that this is possible
    - temporarily build the report-builder using the internally-built jars
    - fix SYSTEM_XALAN conditional to not reset SYSTEM_XML_APIS
      bogusly
    - enable eu and ro langpacks, enable eu help
    - s/libjfreereport-java/libpentaho-reporting-flow-engine-java/
    - update for gcj 4.3; detect libgcj package name/libjawt dir automatically
    - add icedtea-java7-jre to JVM alternatives for JVM recommends/depends.
      Place it before sun-java?-jre
    - don't try to create a libstlport_gcc.so symlink if we don't build
      with stlport and the readlink will fail :)
  * debian/control.in:
    - remove Provides: writer2latex from -writer, bogus (we only provide
      libwriter2latex-java at all, and that with an old version). Depend
      on openoffice.org-writer2latex.
    - build-depend on graphicsmagick-imagemagick-compat instead of simply
      graphicsmagick as ooo-builds Makefile.shared now uses "convert".
      Suggest graphicsmagick-imagemagick-compat | imagemagick.
    - suggest only ttf-dejavu instead of ttf-dejavu | ttf-bitstream-vera;
      OOo now contains the DejaVu fonts. Closes: #461279
    - add USE_SYSTEM_JFREEREPORT conditional
    - build-depend on flex-old instead of flex, see Issue 85508
    - another Replaces: (-core) missed the epoch, thanks Chris Cheney
    - make openoffice.org-writer conflict against -java-common (<< 1:2.3.1)
      (closes: #462477)
  * debian/control.ogltrans.in:
    - depend on openoffice.orgVER-core and openoffice.orgVER-impress
      >> 2.4.0~m237
  * debian/openoffice.org-ogltrans.*.in:
    - remove, ooo-build makes this pre-registered
  * debian/openoffice.org-{ogltrans,base-core}.overrides.lintian:
    - override RPATH warning
  * merge from Ubuntu:
    - debian/rules:
      + Use java-runtime-depends variable for java dependencies.
      + make -gcj depend on libhsqldb-java-gcj
      + some minor parallel build conditional improvements

 -- Rene Engelhard <rene@debian.org>  Tue, 29 Jan 2008 00:25:31 +0100

openoffice.org (1:2.3.1-3) unstable; urgency=low

  * debian/control.in:
    - update VCS headers...
    - add build-conflicts on broken libmono-devs
  * debian/rules:
    - add build-dep on mono-{1,2}.0-devel for new mono packages
      (closes: #458541)
    - mono is now also building sparc packages; enable it

 -- Rene Engelhard <rene@debian.org>  Fri, 28 Dec 2007 16:51:47 +0100

openoffice.org (1:2.3.1-2) unstable; urgency=low

  * ooo-build:
    - update (r11083)
      + buildfix-sal-system.h-no-asm-sigcontext.h.diff: don't include
        <asm/sigcontext.h>, thanks Aurelien Jarno
      + disables SVGImport
  * debian/rules:
    - fix PYTHONPATH setting and remove aotcompile.pyc in clean, too...
    - we also need -l$(PKGDIR)-base/$(OODIR)/program for dh_shlibdeps
      as report-builder links against libdbu
    - remove libsvg conditional; SVGImport is incomplete and now disabled
      in ooo-build
    - etch backport fixes
      - use db4.4
      - use internal icu
      - use STLport on all archs
  * debian/rules, debian/control*.in:
    - add ENABLE_REPORTDESIGN conditional; disable it for etch backports
    - verbosize -report-builders description
  * debian/control.in:
    - add missing epoch to -base-core's Replaces: (closes: #454625)
    - add Replaces: openoffice.org-common (<< 1:2.3.1) to
      openoffice.org-writer as the MediaWiki things moved into -writer
      upstream (closes: #455961)
  * debian/copyright:
    - UTF-8'ize, thanks lintian

 -- Rene Engelhard <rene@debian.org>  Wed, 12 Dec 2007 23:08:31 +0100

openoffice.org (1:2.3.1-1) unstable; urgency=low

  * OpenOffice.org 2.3.1 final (identical to rc1);
    mention CVE-2007-4575 in rc1s changelog
  * merge 2.3.0.dfsg-3 (closes: #453130)
  * upload to unstable
  * ooo-build
    - use ooo-build-2-3 branch
    - update (r11041)
      + patches/src680/fpicker-kde-dialog.diff: keeps filename between 2
        directories now (closes: #427908)
      + fixes right() function in StarBasic (closes: #452267)
      + disables GnomeVFS section for !Novell (closes: #451849)
    - src: update mk GSI from ftp.linux.cz
  * debian/control.gcj.in:
    - "fix" override disparity of -gcj
  * debian/control.in:
    - make -l10n-in depend on -mr-in, too
  * debian/control.ogltrans.in, debian/rules,
    debian/openoffice.org-ogltrans*:
    - package the new "OpenGL rendered transitions" UNO package as
      openoffice.org-ogltrans when ENABLE_OPENGL=y.
  * debian/rules:
    - add $(OOO_ARCHS) to the mesa builddeps
    - fix build with new dpkg-dev
    - reenable cy langpack
    - build against libhyphen-dev which contains a shared lib for ATLinuxhyph
      now
  * debian/rules, debian/aotcompile-256M-default.diff: work around
    java-gcj-compat-devs defaults causing (at least) the i386 buildd
    to OOMing while building the native jars
  * debian/control.in, debian/rules:
    - put libdba680l?.so into a -base-core package. Make -base, -writer and
      -calc depend on it (closes: #381083)
  * debian/README.Debian-source
    - update
  * debian/shell-lib.sh:
    - run unopkg with -env:JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY=1 because
      otherwise the first run with gcj won't find a JRE (and might fail the
      install then). Flush the cache after removing as unopkg doesn't remove
      files on uninstall but marks them as "to-be-removed-on-next-start".
      Thanks Caolan McNamara.
  * debian/README.Debian:
    - update

 -- Rene Engelhard <rene@debian.org>  Wed, 05 Dec 2007 07:15:05 +0100

openoffice.org (1:2.3.0.dfsg-3) unstable; urgency=low

  * ooo-build:
    - update (r10855)
      + patches/emf+/emf+-cppcanvas-emfplus.diff: fix big endian builds

 -- Rene Engelhard <rene@debian.org>  Sat, 17 Nov 2007 13:54:47 +0100

openoffice.org (1:2.3.1~rc1-1) experimental; urgency=high

  * OpenOffice.org 2.3.1 rc1 (OOG680_m9)
    - fixes CVE-2007-4575
  * ooo-build:
    - src: remove vi and ar again (integrated)
  * debian/rules:
    - bump (build-)dep for external hsqldb to >= 1.8.0.9-1
    - fix milestone detection...
  * debian/control.in:
    - build-conflict against libicu36-dev (<= 3.6-7), libicu-dev (<= 3.8-1)
      because we need a function which was private in those versions...
  * debian/README.Debian-source
    - update

 -- Rene Engelhard <rene@debian.org>  Thu, 15 Nov 2007 13:29:04 +0100

openoffice.org (1:2.3.0.dfsg-2) unstable; urgency=low

  * ooo-build:
    - update (r10834)
      + pyuno-rpath-ooodir.diff: fix (closes: #316030)
  * debian/README.Debian-source:
    - update

 -- Rene Engelhard <rene@debian.org>  Thu, 15 Nov 2007 13:26:48 +0100

openoffice.org (1:2.3.0.dfsg-1) unstable; urgency=low

  * clean jfreereport sources included in OOo from binary-only jars
  * upload to unstable
  * ooo-build
    - update (r10794)
      - jvmfwk-detect-removed-java.diff: try autodetection if it is allowed
        and the current JRE has been removed (hopefully closes: #416242,
        please reopen if not)
    - src:
      - update GSIs from ftp.linux.cz: da km mk sl vi
      - add ar GSI from from i#83301
  * debian/rules:
    - since 2.3.0 final we need --enable-dbus explicitely
    - remove obsolete glitz build-dep
    - reenable -gcj (closes: #449201) and bump build-dep on
      java-gcj-compat-dev for this
    - fix logic error preventing mozilla-openoffice.org having
      real content, oops (closes: #449528)
    - use system jfreereport libs
    - reenable ar langpack
    - add libfontconfig1-dbg to DBG_DBG_SUGGESTS
    - Adapt for STLport5 patchset not applied anymore. Remove STLport5
      support.
    - Build --without-stlport4 (closes: #294105). Keep STLport4 for i386
      now due to compatibility with upstream OOo and binary-only stuff
    - fix -dbg suggests on libstdc++6 (we want libstdc++6-4.x-dbg)
  * debian/control.in:
    - XS-Vcs-* -> Vcs-*
    - add a conflict against libicu38 (= 3.8~d01-1)
  * debian/control.{,gcj}.in:
    - depend/recommend (on) java-gcj-compat instead of gij | java-gcj-compat
      as "gij" alone doesn't seem to be sufficient to make OOo know there's
      a "Free Software Foundation" JDK (closes: #440899)
    - s/j2re1.4/sun-java5-jre/
  * debian/shell-lib.sh: fix again to match what a plain upstream build
    creates when embedding the extension in the installset...

 -- Rene Engelhard <rene@debian.org>  Tue, 13 Nov 2007 08:34:15 +0100

openoffice.org (1:2.3.0-4) experimental; urgency=medium

  * ooo-build:
    - update (r10582)
  * debian/control.mozilla.in:
    - recommend konqueror-nsplugins (closes: #446911)
  * debian/control.in:
    - build-conflict against libicu-dev (= 3.8~d01-1) and rebuild against
      libicu-dev 3.8-1 (closes: #447735)
    - stop recommending nfs-common because people now need to install
      nfs-common anyway when they want to use NFS (closes: #424761)
  * deian/rules:
    - fix qstart.desktop installation. Yes, it's not obsolete (why did I thnk
      that?) and ended up in the wrong package (closes: #447732)

 -- Rene Engelhard <rene@debian.org>  Wed, 24 Oct 2007 11:19:24 +0200

openoffice.org (1:2.3.0-3) experimental; urgency=medium

  * ooo-build:
    - update (r10550)
      + ooo82608.vcl.gtkbadfree.diff: backport fix from i#82608 to fix
        bad free on theme resources (closes: #444741)
    - src/: (re)add biblio.tar.bz2
  * debian/rules:
    - readd $(OOO_ARCHS) at neon builddep which got lost
    - add a libstlport_gcc.so symlink in /usr/lib/openoffice/program when
      using STLport4 to not rely on libstlport4.6-dev where binary-only
      components would expect a libstlport_gcc.so
    - look for Autodoc_DiagnosticMessages.txt in the correct path...
    - add conditional for --enable-opengl (cws transogl1)
  * debian/control.in:
    - build-conflict against nvidia-glx-dev for safety
    - build-conflict against broken libicu36-devs on amd64, see #447275
  * debian/control.in, debian/rules:
    - adapt for new qstart implementation in ooo-build, which apparently
      makes ooqstart and qstart.desktop obsolete

 -- Rene Engelhard <rene@debian.org>  Sat, 20 Oct 2007 18:13:43 +0200

openoffice.org (1:2.3.0-2) experimental; urgency=low

  * ooo-build:
    - update (r10478)

  [ Rene Engelhard ]
  * debian/rules:
    - remove bogus curl conditional which was temporary but slipped in...
    - fix Developer Snapshot detection to match on x.y.z~mX
    - migrate from num-cpus= to parallel= in DEB_BUILD_OPTIONS, the latter
      is the quasi standard and will also be used by -j of the new
      dpkg-buildpackage
    - fix ooo-extension.desktop fixing and actually install it in the right
      target...
    - we build against libcurl3-gnutls, so build against -gnutls for neon, too
    - default to -P<number of cores> for PARALLEL_BUILD=y
    - build against neon 0.27.x
    - get rid of Autodoc_DiagnosticMessages.txt completely
  * debian/control.in:
    - make -report-builder depend on -java-common (>= 1:2.3.0~oog680m1) as
      that apparently is needed
    - remove long obsolete debconf depends; we don't use debconf anymore
  * debian/copyright:
    - point to /usr/share/common-licenses/LGPL-2.1 instead of just LGPL
      as OOo is LGPL 2.1 only
  * debian/control.mozilla.in, debian/rules:
    - don't build mozilla-openoffice.org on amd64/ppc64, broken
  * debian/*.overrides.lintian.in: adapt for new lintian
  * merge from Ubuntu:
    - debian/control.in: Build openoffice.org-officebean only on architectures
      with java support

  [ Mirco Bauer ]
  * debian/rules:
    - use LC_ALL=C instead of LANG=C for date call, else LC_ALL or LC_TIME
      might override it.
    - added mono-jit-dbg and mono-dbg to suggest list for debug packages
  * debian/control.mono.in:
    - enhanced package description

 -- Rene Engelhard <rene@debian.org>  Tue, 16 Oct 2007 17:31:47 +0200

openoffice.org (1:2.3.0-1) experimental; urgency=low

  * OpenOffice.org 2.3.0 final (identical to 2.3.0rc3)
  * ooo-build:
    - update (r10301)
      + sc-preserve-imp-opts.diff: fix order (closes: #403128), thanks
        Nagy Elemer Karoly
      + ucb-no-CURL_NO_OLDIES.diff: don't build with -DCURL_NO_OLDIES
        (closes: #442338)
  * debian/changelog:
    - mention fix for the tiff bug in 2.3.0~src680m224-1s changelog
  * debian/rules:
    - honour nocheck at test:
  * debian/control.in: Build-Conflict against libc6-dev (= 2.6.1-3) and
    libc6-dev (= 2.6.1-3) on i386/amd64 as sigcontext.h is broken
    there.

 -- Rene Engelhard <rene@debian.org>  Sun, 16 Sep 2007 11:11:08 +0200

openoffice.org (1:2.3.0~rc3-1) experimental; urgency=low

  * OpenOffice.org 2.3.0rc3 (OOG680_m5)
  * ooo-build:
    - update (r10271)
      + build with hash-style=both
      + (temporarily) disables SELinux patch again (closes: #441380)
    - src: update GSIs: da mk; remove *.log
  * debian/rules:
    - add support to build/run unit tests. For now, ignore all errors
      (bugs in the build); disable per default
  * debian/README.Debian-source: update
  * debian/watch: add
  * debian/openoffice.org-impress.mime: run Impress with -show for .pps

 -- Rene Engelhard <rene@debian.org>  Tue, 11 Sep 2007 21:28:10 +0200

openoffice.org (1:2.3.0~rc2-1) experimental; urgency=low

  * OpenOffice.org 2.3.0rc2 (OOG680_m4)
  * ooo-build:
    - update (r10223)
    - src: update GSIs: bg cs da et vi
  * debian/rules:
    - build against db4.5 on sid (closes: #431786)
    - build with system-boost again
    - remove apparently obsolete OOO_LICENSE change to the GSIs (except
      lv and sr-CS/sh-YU which apparently still need it)
    - do not corrupt the ku GSI
  * debian/control.*.in:
    - migrate to new Homepage: field instead of adding it to the package
      description
  * debian/README.Debian-source: s/2.2.0/2.3.0/

 -- Rene Engelhard <rene@debian.org>  Fri,  7 Sep 2007 08:10:26 +0200

openoffice.org (1:2.3.0~rc1-1) experimental; urgency=low

  * OpenOffice.org 2.3.0rc1 (OOG680_m3)
  * ooo-build:
    - update (r10187)
      + jvmfwk-gij-paths.diff: update for new gcj-4.2 packages
      + jawt-check-cleanup.diff: clenup jawt check to not expect -lgcj
        (only needed with long obsolete libgcjawt). As we now only
        have a dependency on libjawt.so which all supported JDKs have,
        and don't have a dependency on a specific gcj lib anymore we
        can just depend (or-ed) on all supported JDKs.
        Indirectly closes: #439287
      + ooo80816.selinux.bridges.diff: add patch from Fedora to make OOo
        work under SELinux (closes: #440105)
      + src/: update GSIs from ftp.linux.cz: bg cs eo et fi mk vi
  * debian/README.Debian: mention myspell-hy, myspell-fa, hunspell-ar
  * debian/rules:
    - BUILD_JARS_NATIVE=n until gcj-4.2 is unbroken
    - actually install the binfilters...
    - don't specify --with-java=gij anymore to use javac -> ecj from
      java-gcj-compat on sid
    - (build-)depend on libhsqldb-java (>= 1.8.0.8-1)
    - don't run dh_icons on etch backports
    - remove PATH setting for icu tools, now handled by configure
    - remove $(PATCHSET)64 handling, obsolete
    - temporarily disable cy, as it breaks building sbasics help

 -- Rene Engelhard <rene@debian.org>  Sun,  2 Sep 2007 09:12:11 +0200

openoffice.org (1:2.3.0~oog680m2-1) experimental; urgency=medium

  * new upstream snapshot (OOG680_m2)
    - doesn't "translate" function names into german in hebrew calc anymore
      (closes: #365964)
  * ooo-build:
    - update (r10111)
      - ooo59127.vcl.honourcairofont.diff: fix for gdk hang. [CC]
        (closes: #433870)
      - cairo-canvas-ppc-fix.diff: fix endianness to fix yellow color in
        presentation mode under cairo (closes: #339439)
    - src: update GSIs from ftp.linux.cz: bg cs et fi gl sl vi
  * debian/control.in:
    - fix libpq-dev builddep, thanks calc
    - make the openoffice.org metapackage depend on openoffice.org-officebean as
      the officebean is a "standard part of the office"
  * debian/control.qa.in:
    - make -qa-tools conflict against openoffice.org-core (<< 1:2.3.0~oog680m2) as m1 breaks
      the testtool and it's already uploaded..
  * debian/rules:
    - remove some more occurances of conditionals I missed to remove
      in 2.3.0~src680m225-1
    - remove RID_STR_EXTENSION_NOT_PRESENT translation from the GSIs so that
      it is not merged (we changed the string)
    - bump HELP_L10N_VIRTUAL_VERSION to 2.3
  * merge from Ubuntu:
    - fix JAWT_DEPENDS for new gcj-4.2

 -- Rene Engelhard <rene@debian.org>  Thu, 23 Aug 2007 00:21:59 +0200

openoffice.org (1:2.3.0~oog680m1-1) experimental; urgency=low

  * new upstream snapshot (OOG680_m1)
    - makes unopkg being able to handle bundled Java extensions
  * ooo-build:
    - update (r10077)
      + cws-dba23e.diff: fix system-hsqldb
    - src/: Get fixed be-BY GSI from Issue 79966
  * debian/shell-lib.sh, debian/openoffice.org-report-builder.{pre,post}*.in:
    impove maintainer scripts (based on cws jl68). Check whether the extension
    is registered before trying to remove it (it's not in case unopkg fails,
    and we should be able to recover)
  * debian/control.in:
    - make -report-builder depend on -core >> 1:2.3.0~oog680m1 as we need the
      fixes from cws jl68
    - add Homepage: for the report-builder extension
  * debian/control.in:
    - fix -devs description; Xmerge Javadoc is not there for now, mention
      gsicheck instead
  * debian/rules:
    - fix control target dependencies
    - remove hack for #340468; seems to be not needed anymore
    - readd MySQL, MaxDB and PostgreSQL JDBC drivers to
      UNO_JAVA_JFW_CLASSPATH_URLS (removed in m224-1 due to the hsqldb
      problems fixed in dba23e)
    - one more lintian/.desktop fix
    - build-depend on libicu-dev; 3.8 changed the -dev name (and 3.4 and 3.6
      provide libicu-dev)
    - update for OOG680
    - handle epochs in $(BINARY_VERSION)
    - fix X-KDE-Protocols addition to not add it a second, third etc. time on
      incremental builds
    - ooo-extension.desktop also needs Application; removed
  * debian/control.{postgresql,}.in, debian/rules,
    debian/openoffice.org-sdbc-postgresql.*: package PostgreSQL SDBC Driver
    from http://dba.openoffice.org/drivers/postgresql/ (closes: #346475)
  * debian/copyright: update from readlicense_oo/html/THIRDPARTYLICENSE.html
    (removing stuff which is not (anymore) in OOos source...) and
    reportdesign/util/THIRDPARTYLICENSE.html

 -- Rene Engelhard <rene@debian.org>  Thu, 16 Aug 2007 12:59:20 +0200

openoffice.org (2.3.0~src680m225-1) experimental; urgency=low

  * new upstream snapshot (SRC680_m225)
  * ooo-build:
    - update (r10029)
    - src: update GSIs from ftp.linux.cz: bg cs dz et fi mk sk
  * debian/control.in:
    - build-conflict against gjdoc (= 0.7.8-2) [RE]
    - make -base suggest -report-builder and -report-builder enchance
      Base [RE]
  * debian/rules:
    - clean up multi-threaded build support [CC, RE]
    - remove share/xdgs .desktop files (except qstart.desktop), not
      needed [RE]
    - enable system-libwpg on sid [RE]
      (it's on p.d.o/~rene/libwpg while in NEW)
    - fix PRUNE_OOOBUILD conditional [RE]
    - remove removal of the Sun logo from the BrOffice.org splashs again,
      upstream now also has nologo versions for them [RE]
  * debian/*:
    - remove Ubuntu conditionals added in -1 again, it makes
      the rules for Debian even harder to read/understand than
      it's even now... [RE]
  * debian/soffice.sh, debian/rules:
    - install /etc/openoffice/soffice.sh, merged from Ubuntu. [CC, RE]
  * debian/rules, debian/overrides.lintian:
    - fix or override (package depends on package containing the file)
      lintians new desktop warnings [RE]
  * debian/rules, debian/control.in, debian/openoffice.org-report*:
    component got renamed to sun-report-builder. sigh. adapt [RE]

 -- Rene Engelhard <rene@debian.org>  Wed,  8 Aug 2007 18:39:20 +0200

openoffice.org (2.3.0~src680m224-1) experimental; urgency=high

  * new upstream snapshot (SRC680_m224)
    - fixes joining cells in writer tables (closes: #218281)
    - fixes text width in PDF export (closes: #408209)
    - adds fy_NL localedata (closes: #413205)
    - adds option to ignore printer settings from documents (closes: #428646)
    - fixes sheet printing in calc (what to print now choosable easily)
      (closes: #386250)
    - fixes tiff heap overflow (CVE-2007-2834)
  * ooo-build:
    - use trunk again
    - update (r10006)
      + apply Split section. Fixes the binfilter split so that StarWriter
        3.0-5.0 etc. do not appear anymore when -filter-binfilter is not
        installed (indirectly closes: #421274)
    - src/:
      + add updated GSIs from ftp.linux.cz:
        af be-BY bg cs cy da dz eo et fi ga ka ku lt mk nb ne nn sl tg vi
      + add uz GSI from cwx localisation21 [RE]
  * debian/rules, debian/Adobe-Core35_AFMs-314.tar.gz.uu: remove, unneeded
    [RE]
  * debian/rules:
    - update for 2.3 [RE]
    - add ppc64 test-wise [RE]
    - reenable mr-IN since now fixed [RE]
    - build-depend on libneon26 again, got fixed and is the only supported
      version since m219 anyway [RE]
    - add conditional for system-libsvg, enable it for sid/experimental [RE]
    - install headless vcl plugin into -headless [RE]
    - remove debian/libuno-cil.installcligac in clean [RE]
    - set HELP_L10N_VIRTUAL_VERSION to $(shell $(UPSTREAM_VERSION) | tr [~]
      [\\-]) [CC]
    - suggest libc*-dbg [RE]
    - build with --enable-openxml to get the OOXML extensions for the bash
      completion [RE]
    - don't manually split binfilters anymore [RE]
    - build-depend on gperf for OOXML patchset [RE]
    - fix some stuff for etch backports [RE]
    - install splash screens directly from OOos source tree after fixing
      their RGBness and removing the Sun logo from the BrOffice.org splash
      while we don't have a nologo variant upstream yet (thanks Martin Hasch
      for the conversion hint and André Schnabel for the needed (gm) convert
      statement for the "Sun removal") [RE]
    - migrate to graphicsmagick as convert from imagemagick (at least etchs)
      does create a broken BMP out of the Sun logo removal step.. [RE]
    - reenable km again due to demand of the Khmer people... [RE]
    - uuencode all ooo-build/desktop icons [CC]
    - add USE_SYSTEM_VIGRA conditional, enable it [RE]
    - install *updchk* again, as the extension manager UI now apparently
      needs this one, too... [RE]
    - wrap various java code with ENABLE_JAVA [CC]
    - wrap ooo-build pruning with PRUNE_OOOBUILD [CC]
    - simplify uuencode/uudecode code [CC]
    - add DBVER substition [CC]
    - fix testtoolrc (non)installation [RE]
    - enable uz langpack [RE]
  * debian/control.in:
    - build-depend on libxml-parser-perl [RE]
    - Add XS-Vcs-{Bzr,Svn} fields [RE]
    - we need to build-depend on dmake (>= 1:4.7) [RE]
    - build-depend on netpbm [RE]
    - remove imagemagick; add graphicsmagick [RE]
    - remove version from java-common-depends since it is substituted [CC]
  * debian/*.menu, debian/*.overrides.lintian:
    - update for 2.3 [RE]
  * debian/README.Debian-source: update [RE]
  * merge from Ubuntu:
    - make system-dmake conditional [RE]
    - add Ubuntu conditonals [CC]
  * debian/br{intro,about}.bmp.uu: remove, obsolete [RE]
  * debian/scripts/fix_image_rgb: add [RE]
  * debian/openoffice.org-core.shlibs.local: add
    libuno_purpenvhelpergcc3 [RE]
  * debian/rules, debian/openoffice.org-reportdesigner*: properly
    install/package the reportdesigner extension [RE]
  * debian/rules, debian/*.menu.in, debian/*.overrides.lintian.in:
    add version number to the icon= entry dynamically [RE]
  * debian/NEWS: remove, obsolete [CC]

   (CC = Chris Cheney)

 -- Rene Engelhard <rene@debian.org>  Sun,  5 Aug 2007 17:42:24 +0200

openoffice.org (2.2.1-7) unstable; urgency=low

  * ooo-build:
    + update (r9936)
    + src:
      - add he GSI from Issue 79651
        . fixes hardcoded 2.0.3 in recovery dialog (closes: #432770)
        . removes bogus 2.0.3 from Help->About ttle (closes: #432771)
  * merge from 2.3/experimental branch:
    - debian/rules:
      + fix some stuff for etch backports
      + suggest libc*-dbg
      + reenable km again due to demand of the Khmer people...
    - debian/*.mime: move Star* into a -filter-binfilter.mime [RE]
  * debian/control.in:
    - add build-conflicts against
      libxul-dev (= 1.8.0.13~pre070720-0etch1) - broken security update, see
      #434844
  * debian/README.Debian: update for myspell-af and
    openoffice.org-hyphenation-it
  * debian/rules:
    - suggest openoffice.org-ctl-he at -l10n-he

 -- Rene Engelhard <rene@debian.org>  Mon, 30 Jul 2007 22:17:05 +0200

openoffice.org (2.2.1-6) unstable; urgency=low

  * ooo-build:
    - update (r9849)
  * debian/*.menu:
    - adapt to the new menu sections
    - fix icon=
  * debian/openoffice.org-*.overrides.lintian:
    - update overrides for menu icons
  * debian/rules:
    - fix order in USE_LIBCURL4
    - fix setting of path for the ICU utils, thanks calc
    - (temporarily) stop install xmerge javadoc as its build broke with ant
      1.7.0. Fixes FTBFS because files were tried to be installed which aren't
      there (the ant step doesn't fail...)
    - build against lp-solve (>= 5.5.0.10-4) and libsuitesparse
      (closes: #433486)

 -- Rene Engelhard <rene@debian.org>  Wed, 18 Jul 2007 10:28:49 +0200

openoffice.org (2.2.1-5) unstable; urgency=low

  * ooo-build:
    - update (r9703)
      + libpaper-support.diff: backport suppressing of
        "paperconf: command not found" from cws vcl79 (closes: #430141)
  * debian/control.mozilla.in:
    - stop recommending mozilla-browser (closes: #431269)
  * debian/rules:
    - remove FontOOo from /usr/lib/openoffice/share/basic/launcher/script.xlb,
      see issue 79153
    - stop running the smoketest again...
    - revert to using libstlport4.6, sorry Torsten...

 -- Rene Engelhard <rene@debian.org>  Wed,  4 Jul 2007 10:48:34 +0200

openoffice.org (2.2.1-4) unstable; urgency=low

  * debian/rules: fix lp-solve builddeps, oops

 -- Rene Engelhard <rene@debian.org>  Fri, 29 Jun 2007 17:47:56 +0200

openoffice.org (2.2.1-3) unstable; urgency=low

  * debian/shell-lib.sh: do not parse /var/lib/dpkg/status diretcly, use
    dpkg-query -W -f='${Conffiles}'
  * ooo-build:
    - update (r9666)
      + distro-configs: --disable-access, broken, thanks Mechtilde Stehmann
        for the reminder
      + fix smoketestoo_native
  * debian/rules:
    - --disable-access; remove BUILD_MDBTOOLS conditionals, see above
    - improve test target; make it honour nocheck for DEB_BUILD_OPTIONS,
      run smoketest per default
    - remove some ifeq "$(ETCH_BACKPORT)" "y" conditionals, one to go...
    - make -gcj depend on bsh-gcj
    - add (Build-)Conflicts against libcairo2 (= 1.4.8-1) (closes: #430135),
      cairo 1.4.10 is fixed
    - install xmerge javadoc into -dev-doc
    - change ooo-template.desktop also for BrOffice.org
  * debian/broffice.org*.in: add diversion for ooo-template.desktop
  * debian/openoffice.org-impress.mime: add pps
  * debian/openoffice.org.control.bug: fix thinko (s/base/core/)
  * debian/control.mozilla.in: remove unneeded ${misc:Depends} at
    mozilla-openoffice.org

 -- Rene Engelhard <rene@debian.org>  Fri, 29 Jun 2007 01:04:37 +0200

openoffice.org (2.2.1-2) unstable; urgency=low

  * ooo-build:
    - update (r9584)
      + canvas_x64.diff: fixes vanvas build with internal boost on amd64
  * debian/rules:
    - adapt libmythes-dev build for canonical upstream tarball name
      (closes: #428850)
    - do not add the internal libxmlsec to openoffice.org-cores .shlibs
    - add SYSTEM_LIBWPG conditional, not enabled anywhere yet
    - use internal boost on amd64, too (closes: #425528 again)
    - fix typos (s/oooqstart/ooqstart/)

 -- Rene Engelhard <rene@debian.org>  Thu, 14 Jun 2007 16:53:01 +0200

openoffice.org (2.2.1-1) unstable; urgency=low

  * OOo 2.2.1 final release without source changes
    (with new, fixed orig.tar.gz removing some non-free stuff which
    were left in to the scripts' bug and a overseen upstream change)
  * mention CVE-2007-0245 fix in 2.2.1~rc1-1's changelog
  * ooo-build:
    - update (r9562)

 -- Rene Engelhard <rene@debian.org>  Fri,  8 Jun 2007 17:24:56 +0200

openoffice.org (2.2.1~rc3-3) unstable; urgency=low

  * ooo-build
    - update (r9534)
      + wpgimporter.diff: wpgimport moved intro -draw
  * debian/control.in:
    - update Replaces:
  * debian/rules:
    - fix debian/rules typo at adding libmono0-dbg to -dbgs Suggests
      which made OOo FTBFS on archs where mono is enabled

 -- Rene Engelhard <rene@debian.org>  Wed,  6 Jun 2007 12:59:10 +0200

openoffice.org (2.2.1~rc3-2) unstable; urgency=low

  * ooo-build:
    - update (r9520)
  * debian/rules:
    - use internal boost (closes: #425528)
    - add libmono0-dbg to -dbgs Suggests:
    - handle libgcj8-0-awt of gcj-4.2
  * build in a clean env without DEB_BUILD_OPTIONS="lang=en-US de" to
    actually build with all languages... *sigh*, again (closes: #427547)

 -- Rene Engelhard <rene@debian.org>  Mon,  4 Jun 2007 23:10:26 +0200

openoffice.org (2.2.1~rc3-1) unstable; urgency=low

  * OOo 2.2.1rc3 (aka OOF680_m18)
    - fixes CVE-2007-2754 for the (unused) internal freetype copy
  * ooo-build:
    - update (9495)
      + distro-configs/Debian*conf.in: --without-nas
  * debian/rules:
    - stop symlinking simpress' help files as that breaks searching
      in it. ship them again instead of hardlinking them as hardlinks
      are not allowed/discouraged (closes: #411693)
    - build-depend on libcurl{3,4}-gnutls-dev (closes: #391671)
    - remove unneeded diriso setting at help copying. confusing and not
      needed anymore.
    - fix qstart.desktop - again (closes: #415180)
  * debian/control.in:
    - remove libaudio-dev builddep
    - add Replaces: broffice.org (<< 2.2.1~rc1) to openoffice.org-common
      to fix upgrades from etch with broffice.org installed.  Thanks
      Otavio Salvador for the report

 -- Rene Engelhard <rene@debian.org>  Fri,  1 Jun 2007 11:05:29 +0200

openoffice.org (2.2.1~rc1-1) unstable; urgency=high

  * OOo 2.2.1rc1 (aka OOF680_m16)
    - fixes RTF parser heap overflow (CVE-2007-0245)
  * build in a clean env without DEB_BUILD_OPTIONS="lang=en-US" to
    actually build with all languages, oops
  * ooo-build:
    - update (r9418)
    - distro-configs/Debian*.conf.in: remove --with-libpaper-link
      libpaper is GPL. (closes: #423906)
    - libpaper-support.diff: update to version in cws vcl78 using the
      paperconf command.
  * merge 2.2.0-7 (closes: #422492, #422530)
  * debian/rules:
    - don't remove updatefeed.uno.so, the extension manager needs it
      (closes: #422870)
    - fix some files in the udk-common-ref doc-base file
    - updates for 2.2.1
    - remove generated udk-common-* doc-base files in clean
    - don't add Autodoc_DiagnosticMessages.txt into udk-{cpp,common}-refs
      doc-base.
  * debian/broffice.org.*.in:
   - add about.bmp to the diversions
  * debian/control.in:
    - Stop build-depending on libpaper-dev; suggest libpaper-utils (see above)
    - (again) only suggest the packages from -style-*. Somehow got lost.
      (closes: #423950)

 -- Rene Engelhard <rene@debian.org>  Tue, 15 May 2007 13:15:22 +0200

openoffice.org (2.2.1~oof680m15-1) experimental; urgency=low

  * new upstream milestone (OOF680_m15)
  * ooo-build:
    - update (r9359)

 -- Rene Engelhard <rene@debian.org>  Sat,  5 May 2007 00:04:02 +0200

openoffice.org (2.2.0-7) unstable; urgency=low

Results 1 - 1 of 1
Help - FTP Sites List - Software Dir.
Search over 15 billion files
© 1997-2017 FileWatcher.com